Commit 8a51cc79 authored by Clint Adams's avatar Clint Adams

darcs-monitor: build with ghc 8 in experimental

parent e02ce388
darcs-monitor (0.4.2-11) UNRELEASED; urgency=medium darcs-monitor (0.4.2-11) experimental; urgency=medium
[ Dmitry Bogatov ] [ Dmitry Bogatov ]
* Use secure (https) uri in Vcs-Git field in 'debian/control' * Use secure (https) uri in Vcs-Git field in 'debian/control'
* Bump standards version to 3.9.8 (no changes needed) * Bump standards version to 3.9.8 (no changes needed)
* Convert `debian/copyright' to dep5 format * Convert `debian/copyright' to dep5 format
[ Gianfranco Costamagna ] [ Clint Adams ]
* Fix VCS fields * Temporarily build-depend on ghc 8.
-- Dmitry Bogatov <KAction@gnu.org> Tue, 10 May 2016 09:34:42 +0300 -- Clint Adams <clint@debian.org> Sun, 16 Oct 2016 01:20:21 -0400
darcs-monitor (0.4.2-10) unstable; urgency=medium darcs-monitor (0.4.2-10) unstable; urgency=medium
......
Source: darcs-monitor Source: darcs-monitor
Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org> Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Uploaders: Joachim Breitner <nomeata@debian.org> Uploaders:
Joachim Breitner <nomeata@debian.org>,
Priority: optional Priority: optional
Section: vcs Section: vcs
Build-Depends: debhelper (>= 9), Build-Depends:
cdbs, cdbs,
debhelper (>= 9),
ghc (>= 8),
haskell-devscripts (>= 0.10), haskell-devscripts (>= 0.10),
ghc,
libghc-mtl-dev,
libghc-haxml-dev (>= 1:1.25),
libghc-haxml-dev (<< 1:1.26), libghc-haxml-dev (<< 1:1.26),
libghc-haxml-dev (>= 1:1.25),
libghc-mtl-dev,
Standards-Version: 3.9.8 Standards-Version: 3.9.8
Homepage: http://wiki.darcs.net/RelatedSoftware/DarcsMonitor Homepage: http://wiki.darcs.net/RelatedSoftware/DarcsMonitor
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/ Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/tree/p/darcs-monitor
Vcs-Git: https://anonscm.debian.org/git/pkg-haskell/DHG_packages.git Vcs-Git: https://anonscm.debian.org/git/pkg-haskell/DHG_packages.git
Package: darcs-monitor Package: darcs-monitor
Architecture: any Architecture: any
Depends: ${shlibs:Depends}, Depends:
${misc:Depends},
darcs (>= 1.0.0rc2-1), darcs (>= 1.0.0rc2-1),
Recommends: exim4 | mail-transport-agent, ${misc:Depends},
${shlibs:Depends},
Recommends:
exim4 | mail-transport-agent,
Description: Darcs add-on that sends mail about newly pushed changes Description: Darcs add-on that sends mail about newly pushed changes
It is often desirable to send mail about new changes to software to It is often desirable to send mail about new changes to software to
a mailing list as soon as they are committed to a version control a mailing list as soon as they are committed to a version control
......
...@@ -29,4 +29,4 @@ License: GPL-2+ ...@@ -29,4 +29,4 @@ License: GPL-2+
along with this program. If not, see <http://www.gnu.org/licenses/>. along with this program. If not, see <http://www.gnu.org/licenses/>.
. .
On Debian system, copy of GNU Lesser General Public License version 2 On Debian system, copy of GNU Lesser General Public License version 2
is also located at `/usr/share/common-licenses/GPL-2' is also located at `/usr/share/common-licenses/GPL-2'
\ No newline at end of file
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment