Commit 8a9f91dc authored by Clint Adams's avatar Clint Adams

tar: enable testsuite

parent 97aec27c
haskell-tar (0.5.1.0-2) unstable; urgency=medium
* Enable testsuite.
-- Clint Adams <clint@debian.org> Mon, 16 Apr 2018 13:18:30 -0400
haskell-tar (0.5.1.0-1) unstable; urgency=medium
[ Ilias Tsitsimpis ]
......
......@@ -9,6 +9,10 @@ Build-Depends:
ghc (>= 8),
ghc-prof,
haskell-devscripts (>= 0.13),
libghc-bytestring-handle-dev,
libghc-quickcheck2-dev,
libghc-tasty-dev (>= 0.10),
libghc-tasty-quickcheck-dev (>= 0.8),
Build-Depends-Indep: ghc-doc
Standards-Version: 4.1.4
Homepage: http://hackage.haskell.org/package/tar
......
--- a/tar.cabal
+++ b/tar.cabal
@@ -91,8 +91,8 @@
deepseq,
bytestring-handle,
QuickCheck == 2.*,
- tasty >= 0.10 && <0.12,
- tasty-quickcheck == 0.8.*
+ tasty >= 0.10,
+ tasty-quickcheck >= 0.8
if flag(old-time)
build-depends: directory < 1.2, old-time
#!/usr/bin/make -f
DEB_BUILD_DEPENDENCIES = build-arch
DEB_ENABLE_TESTS = no # testsuite currently requires bytestring-handle which is not packaged
DEB_ENABLE_TESTS = yes
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/hlibrary.mk
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment