Commit 97aec27c authored by Clint Adams's avatar Clint Adams

polynomial: enable testsuite

parent 01d55008
haskell-polynomial (0.7.3-2) unstable; urgency=medium
* Enable testsuite.
-- Clint Adams <clint@debian.org> Mon, 16 Apr 2018 13:02:24 -0400
haskell-polynomial (0.7.3-1) unstable; urgency=medium
* New upstream release
......
......@@ -16,6 +16,11 @@ Build-Depends:
libghc-vector-space-prof,
libghc-vector-th-unbox-dev (>= 0.2.1),
libghc-vector-th-unbox-prof,
libghc-hunit-dev (>= 1.2),
libghc-quickcheck2-dev,
libghc-test-framework-dev,
libghc-test-framework-hunit-dev,
libghc-test-framework-quickcheck2-dev,
Build-Depends-Indep:
ghc-doc,
libghc-vector-doc,
......
--- a/polynomial.cabal
+++ b/polynomial.cabal
@@ -63,7 +63,7 @@
main-is: Tests.hs
build-depends: base >= 3 && <5,
- HUnit == 1.2.*,
+ HUnit >= 1.2,
polynomial,
QuickCheck >= 2,
test-framework,
#!/usr/bin/make -f
DEB_ENABLE_TESTS = yes
DEB_CABAL_PACKAGE = polynomial
DEB_DEFAULT_COMPILER = ghc
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment