Commit 9d620151 authored by Ilias Tsitsimpis's avatar Ilias Tsitsimpis

cgi: Relax build-dep on exceptions and doctest

parent 560a5245
haskell-cgi (3001.3.0.2-7) unstable; urgency=medium
* Relax build-dep on libghc-exceptions-dev and libghc-doctest-dev
-- Ilias Tsitsimpis <iliastsi@debian.org> Sat, 20 Oct 2018 14:18:13 +0300
haskell-cgi (3001.3.0.2-6) unstable; urgency=medium haskell-cgi (3001.3.0.2-6) unstable; urgency=medium
* Remove build dependency on libghc-parsec3-dev (provided by ghc- * Remove build dependency on libghc-parsec3-dev (provided by ghc-
......
...@@ -12,7 +12,7 @@ Build-Depends: ...@@ -12,7 +12,7 @@ Build-Depends:
ghc (>= 8.4.3), ghc (>= 8.4.3),
ghc-prof, ghc-prof,
haskell-devscripts (>= 0.13), haskell-devscripts (>= 0.13),
libghc-exceptions-dev (<< 0.9), libghc-exceptions-dev,
libghc-exceptions-prof, libghc-exceptions-prof,
libghc-multipart-dev (<< 0.2), libghc-multipart-dev (<< 0.2),
libghc-multipart-dev (>= 0.1.2), libghc-multipart-dev (>= 0.1.2),
...@@ -26,7 +26,6 @@ Build-Depends: ...@@ -26,7 +26,6 @@ Build-Depends:
libghc-quickcheck2-dev (>= 2.8.1), libghc-quickcheck2-dev (>= 2.8.1),
libghc-quickcheck2-dev (<< 2.12), libghc-quickcheck2-dev (<< 2.12),
libghc-doctest-dev (>= 0.8), libghc-doctest-dev (>= 0.8),
libghc-doctest-dev (<< 0.14),
Build-Depends-Indep: Build-Depends-Indep:
ghc-doc, ghc-doc,
libghc-exceptions-doc, libghc-exceptions-doc,
......
Index: b/cgi.cabal
===================================================================
--- a/cgi.cabal --- a/cgi.cabal
+++ b/cgi.cabal +++ b/cgi.cabal
@@ -48,7 +48,7 @@ @@ -44,11 +44,11 @@ Library
Build-depends:
parsec >= 2.0 && < 3.2,
- exceptions < 0.9,
+ exceptions,
xhtml >= 3000.0.0 && < 3000.3, xhtml >= 3000.0.0 && < 3000.3,
bytestring < 0.11, bytestring < 0.11,
base >= 4.5 && < 5, base >= 4.5 && < 5,
...@@ -9,13 +16,13 @@ ...@@ -9,13 +16,13 @@
containers < 0.6, containers < 0.6,
multipart >= 0.1.2 && < 0.2 multipart >= 0.1.2 && < 0.2
If flag(network-uri) If flag(network-uri)
@@ -72,8 +72,8 @@ @@ -72,8 +72,8 @@ test-suite doctests
ghc-options: -Wall ghc-options: -Wall
build-depends: build-depends:
base base
- , doctest >= 0.8 && < 0.12 - , doctest >= 0.8 && < 0.12
- , QuickCheck >= 2.8.1 && < 2.10 - , QuickCheck >= 2.8.1 && < 2.10
+ , doctest >= 0.8 && < 0.14 + , doctest >= 0.8
+ , QuickCheck >= 2.8.1 && < 2.12 + , QuickCheck >= 2.8.1 && < 2.12
--Executable: printinput --Executable: printinput
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment