Commit b0d49e13 authored by Kei Hibino's avatar Kei Hibino

cabal-debian: fix to generate shlibs:Depends for -utils packages.

parent 996077a4
Index: cabal-debian-4.35.6/src/Debian/Debianize/Finalize.hs
===================================================================
--- cabal-debian-4.35.6.orig/src/Debian/Debianize/Finalize.hs
+++ cabal-debian-4.35.6/src/Debian/Debianize/Finalize.hs
@@ -411,6 +411,8 @@ binaryPackageRelations b typ = zoom A.de
when (typ == B.Development) $ do
B.depends %= (edds ++)
B.depends %= (anyrel "${shlibs:Depends}" : )
+ when (typ == B.Utilities) $
+ B.depends %= (anyrel "${shlibs:Depends}" : )
B.depends %= ([anyrel "${haskell:Depends}", anyrel "${misc:Depends}"] ++)
B.recommends %= (anyrel "${haskell:Recommends}" : )
B.suggests %= (anyrel "${haskell:Suggests}" :)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment