Commit cd8eb1f0 authored by Clint Adams's avatar Clint Adams

snap: patch for newer build-deps

parent b89e3796
haskell-snap (1.1.0.0-2) UNRELEASED; urgency=medium
haskell-snap (1.1.0.0-3) unstable; urgency=medium
* Set Rules-Requires-Root to no.
* Patch for newer build-deps.
-- Clint Adams <clint@debian.org> Sun, 06 May 2018 22:10:35 -0400
-- Clint Adams <clint@debian.org> Mon, 21 May 2018 20:26:32 -0400
haskell-snap (1.1.0.0-1) unstable; urgency=medium
......
......@@ -13,7 +13,7 @@ Build-Depends:
ghc-prof,
haskell-devscripts (>= 0.13),
libghc-aeson-dev (>= 0.6),
libghc-aeson-dev (<< 1.3),
libghc-aeson-dev (<< 1.4),
libghc-aeson-prof,
libghc-attoparsec-dev (<< 0.14),
libghc-attoparsec-dev (>= 0.10),
......@@ -36,17 +36,17 @@ Build-Depends:
libghc-hashable-dev (<< 1.3),
libghc-hashable-dev (>= 1.2.0.6),
libghc-hashable-prof,
libghc-heist-dev (<< 1.1),
libghc-heist-dev (>= 1.0),
libghc-heist-dev (<< 1.2),
libghc-heist-prof,
libghc-lens-dev (>= 3.7.6),
libghc-lens-dev (<< 4.16),
libghc-lens-dev (<< 4.17),
libghc-lens-prof,
libghc-lifted-base-dev (<< 0.3),
libghc-lifted-base-dev (>= 0.2),
libghc-lifted-base-prof,
libghc-map-syntax-dev (<< 0.3),
libghc-map-syntax-dev (>= 0.2),
libghc-map-syntax-dev (<< 0.4),
libghc-map-syntax-prof,
libghc-monad-control-dev (<< 1.1),
libghc-monad-control-dev (>= 0.3),
......@@ -63,8 +63,8 @@ Build-Depends:
libghc-snap-core-dev (<< 1.1),
libghc-snap-core-dev (>= 1.0),
libghc-snap-core-prof,
libghc-snap-server-dev (<< 1.1),
libghc-snap-server-dev (>= 1.0),
libghc-snap-server-dev (<< 1.2),
libghc-snap-server-prof,
libghc-stm-dev (<< 2.5),
libghc-stm-dev (>= 2.2),
......@@ -85,9 +85,8 @@ Build-Depends:
libghc-hunit-dev (<< 1.7),
libghc-quickcheck2-dev (>= 2.4.2),
libghc-quickcheck2-dev (<< 2.11),
libghc-aeson-dev,
libghc-async-dev (>= 2.0.1.5),
libghc-async-dev (<< 2.2),
libghc-async-dev (<< 2.3),
libghc-attoparsec-dev,
libghc-cereal-dev,
libghc-clientsession-dev,
......
--- a/snap.cabal
+++ b/snap.cabal
@@ -103,7 +103,7 @@
Snap.Snaplet.Session.SecureCookie
build-depends:
- aeson >= 0.6 && < 1.3,
+ aeson >= 0.6 && < 1.4,
attoparsec >= 0.10 && < 0.14,
base >= 4 && < 4.11,
bytestring >= 0.9.1 && < 0.11,
@@ -119,16 +119,16 @@
-- snap does work with hashable 1.1.*, but some have complained that
-- the version disjunction causes problems with dependency resolution.
hashable >= 1.2.0.6 && < 1.3,
- heist >= 1.0 && < 1.1,
- lens >= 3.7.6 && < 4.16,
+ heist >= 1.0 && < 1.2,
+ lens >= 3.7.6 && < 4.17,
lifted-base >= 0.2 && < 0.3,
- map-syntax >= 0.2 && < 0.3,
+ map-syntax >= 0.2 && < 0.4,
monad-control >= 0.3 && < 1.1,
mtl >= 2.0 && < 2.3,
mwc-random >= 0.8 && < 0.14,
pwstore-fast >= 2.2 && < 2.5,
snap-core >= 1.0 && < 1.1,
- snap-server >= 1.0 && < 1.1,
+ snap-server >= 1.0 && < 1.2,
stm >= 2.2 && < 2.5,
text >= 0.11 && < 1.3,
time >= 1.1 && < 1.9,
@@ -220,7 +220,7 @@
build-depends:
aeson,
- async >= 2.0.1.5 && < 2.2,
+ async >= 2.0.1.5 && < 2.3,
attoparsec,
base,
bytestring,
--- a/snap.cabal
+++ b/snap.cabal
@@ -255,7 +255,6 @@
@@ -254,7 +254,6 @@
test-framework >= 0.8.0.3 && < 0.9,
test-framework-hunit >= 0.3.0.1 && < 0.4,
test-framework-quickcheck2 >= 0.3.0.3 && < 0.4,
......
rename-snap-binary
no-test-framework-smallcheck
tests-timeout
newer-deps
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment