Commit d410a68a authored by Joachim Breitner's avatar Joachim Breitner

persistent: This package does not actually use Template Haskell, do not claim it does.

parent 406b9478
haskell-persistent (2.1.6-2) unstable; urgency=medium
* This package does not actually use Template Haskell, do not claim it does.
-- Joachim Breitner <nomeata@debian.org> Thu, 23 Jul 2015 15:03:41 +0200
haskell-persistent (2.1.6-1) unstable; urgency=medium
* New upstream version.
......
......@@ -44,7 +44,6 @@ Build-Depends: debhelper (>= 9)
, libghc-tagged-prof
, libghc-fast-logger-dev (>= 2.1)
, libghc-fast-logger-prof
, ghc-ghci
, libghc-text-dev (>= 0.8)
, libghc-text-prof
, libghc-transformers-base-dev
......
Description: TemplateHaskell is unused
Some modules enable the TemplateHaskell extension without actually using it.
Author: Joachim Breitner <nomeata@debian.org>
Forwarded: https://github.com/yesodweb/persistent/issues/427
--- haskell-persistent-2.1.6.orig/Database/Persist/Quasi.hs
+++ haskell-persistent-2.1.6/Database/Persist/Quasi.hs
@@ -2,7 +2,6 @@
{-# LANGUAGE CPP #-}
{-# LANGUAGE PatternGuards #-}
{-# LANGUAGE ViewPatterns #-}
-{-# LANGUAGE TemplateHaskell #-}
module Database.Persist.Quasi
( parse
, PersistSettings (..)
--- haskell-persistent-2.1.6.orig/Database/Persist/Sql/Raw.hs
+++ haskell-persistent-2.1.6/Database/Persist/Sql/Raw.hs
@@ -1,4 +1,3 @@
-{-# LANGUAGE TemplateHaskell #-}
{-# LANGUAGE OverloadedStrings #-}
{-# LANGUAGE FlexibleContexts #-}
module Database.Persist.Sql.Raw where
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment