Commit d88da1af authored by Ilias Tsitsimpis's avatar Ilias Tsitsimpis

diagrams-cairo: Get newer build-deps from hackage

Closes: #880510
parent bc6b792c
haskell-diagrams-cairo (1.4-2) UNRELEASED; urgency=medium
haskell-diagrams-cairo (1.4-2) unstable; urgency=medium
* Change Priority to optional. Since Debian Policy version 4.0.1,
priority extra has been deprecated.
* Use the HTTPS form of the copyright-format URL
* Modify d/watch and Source field in d/copyright to use HTTPS
* Declare compliance with Debian policy 4.1.1
* Get newer build-deps from hackage (Closes: #880510)
-- Ilias Tsitsimpis <iliastsi@debian.org> Wed, 01 Nov 2017 12:14:01 +0200
-- Ilias Tsitsimpis <iliastsi@debian.org> Tue, 07 Nov 2017 15:22:35 +0200
haskell-diagrams-cairo (1.4-1) unstable; urgency=medium
......
......@@ -37,8 +37,7 @@ Build-Depends:
libghc-mtl-dev (>= 2.0),
libghc-mtl-prof,
libghc-optparse-applicative-dev (>= 0.13),
libghc-optparse-applicative-dev (<< 0.14),
libghc-optparse-applicative-dev (>= 0.10),
libghc-optparse-applicative-dev (<< 0.15),
libghc-optparse-applicative-prof,
libghc-pango-dev (<< 0.14),
libghc-pango-dev (>= 0.12.5),
......@@ -49,7 +48,7 @@ Build-Depends:
libghc-statestack-dev (<< 0.3),
libghc-statestack-dev (>= 0.2),
libghc-statestack-prof,
libghc-vector-dev (<< 0.12),
libghc-vector-dev (<< 0.13),
libghc-vector-dev (>= 0.10.0),
libghc-vector-prof,
Build-Depends-Indep:
......
Description: Newer build-deps from hackage
Origin: upstream, https://hackage.haskell.org/package/diagrams-cairo-1.4/revisions/
---
Index: b/diagrams-cairo.cabal
===================================================================
--- a/diagrams-cairo.cabal
+++ b/diagrams-cairo.cabal
@@ -67,10 +67,10 @@ Library
data-default-class >= 0.0.1 && < 0.2,
statestack >= 0.2 && < 0.3,
JuicyPixels >= 3.1.3.2 && < 3.3,
- vector >= 0.10.0 && < 0.12,
+ vector >= 0.10.0 && < 0.13,
array >= 0.4.0 && < 0.6,
bytestring >= 0.9 && < 0.11,
- optparse-applicative >= 0.13 && < 0.14,
+ optparse-applicative >= 0.13 && < 0.15,
transformers >= 0.3 && <0.6,
hashable >= 1.1 && < 1.3
if impl(ghc < 7.6)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment