Commit d9e63146 authored by Joachim Breitner's avatar Joachim Breitner

gitit: new version

parent d897c9ec
gitit (0.11.1.1-1) UNRELEASED; urgency=medium
* New upstream release
-- Joachim Breitner <nomeata@debian.org> Wed, 19 Aug 2015 17:39:04 +0200
gitit (0.10.7-3) unstable; urgency=medium
* Remove bogus dependency on libghc-cgi-*
......
Source: gitit
Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Uploaders: Giovanni Mascellani <gio@debian.org>, Clint Adams <clint@debian.org>, Louis Bettens <louis@bettens.info>, Anthony Towns <ajt@debian.org>, Dmitry Bogatov <KAction@gnu.org>
Priority: extra
Section: haskell
Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Uploaders: Giovanni Mascellani <gio@debian.org>, Clint Adams <clint@debian.org>
, Louis Bettens <louis@bettens.info>, Anthony Towns <ajt@debian.org>
, Dmitry Bogatov <KAction@gnu.org>
Build-Depends:
debhelper (>= 9),
Build-Depends: debhelper (>= 9),
haskell-devscripts (>= 0.9),
dh-linktree,
cdbs,
......@@ -17,147 +14,81 @@ Build-Depends:
libjs-jquery,
libjs-jquery-ui,
libjs-jquery-hotkeys,
# -dev dependencies
, libghc-parsec3-dev
, libghc-pretty-dev
, libghc-pandoc-dev (>= 1.13)
, libghc-pandoc-dev (<< 1.15)
, libghc-pandoc-types-dev (>= 1.12.3)
, libghc-pandoc-types-dev (<< 1.13)
, libghc-mtl-dev
, libghc-highlighting-kate-dev (>= 0.5.0.1)
, libghc-highlighting-kate-dev (<< 0.7)
, libghc-text-dev
, libghc-random-dev
, libghc-network-dev (>= 2.6)
, libghc-network-uri-dev (>= 2.6)
, libghc-network-uri-dev (<< 2.7)
, libghc-utf8-string-dev (>= 0.3)
, libghc-utf8-string-dev (<< 1.1)
, libghc-sha-dev (>= 1)
, libghc-sha-dev (<< 1.7)
, libghc-http-dev (>= 1:4000.0)
, libghc-http-dev (<< 1:4000.3)
, libghc-hstringtemplate-dev (>= 0.6)
, libghc-hstringtemplate-dev (<< 0.9)
, libghc-recaptcha-dev (>= 0.1)
, libghc-filestore-dev (>= 0.6)
, libghc-filestore-dev (<< 0.7)
, libghc-zlib-dev (>= 0.5)
, libghc-zlib-dev (<< 0.7)
, libghc-url-dev (>= 2.1)
, libghc-url-dev (<< 2.2)
, libghc-happstack-server-dev (>= 7.0)
, libghc-happstack-server-dev (<< 7.5)
, libghc-base64-bytestring-dev (>= 0.1)
, libghc-base64-bytestring-dev (<< 1.1)
, libghc-xml-dev (>= 1.3.5)
, libghc-hslogger-dev (>= 1)
, libghc-hslogger-dev (<< 1.3)
, libghc-configfile-dev (>= 1)
, libghc-configfile-dev (<< 1.2)
, libghc-feed-dev (>= 0.3.6)
, libghc-feed-dev (<< 0.4)
, libghc-xss-sanitize-dev (>= 0.3)
, libghc-xss-sanitize-dev (<< 0.4)
, libghc-tagsoup-dev (>= 0.13)
, libghc-tagsoup-dev (<< 0.14)
, libghc-blaze-html-dev (>= 0.4)
, libghc-blaze-html-dev (<< 0.9)
, libghc-json-dev (>= 0.4)
, libghc-json-dev (<< 0.10)
, libghc-ghc-paths-dev
, libghc-safe-dev
, libghc-uri-dev (>= 0.1)
, libghc-uri-dev (<< 0.2)
, libghc-split-dev
, libghc-hoauth2-dev (>= 0.4.2)
, libghc-hoauth2-dev (<< 0.5)
, libghc-http-conduit-dev (>= 2.1.4)
, libghc-http-conduit-dev (<< 2.2)
, libghc-http-client-tls-dev (>= 0.2.2)
, libghc-http-client-tls-dev (<< 0.3)
, libghc-aeson-dev (>= 0.7)
, libghc-aeson-dev (<< 0.10)
, libghc-uuid-dev (>= 1.3)
, libghc-uuid-dev (<< 1.4)
# -prof dependencies
, libghc-parsec3-prof
, libghc-pretty-prof
, libghc-pandoc-prof
, libghc-pandoc-types-prof
, libghc-mtl-prof
, libghc-highlighting-kate-prof
, libghc-text-prof
, libghc-random-prof
, libghc-network-prof
, libghc-network-uri-prof
, libghc-utf8-string-prof
, libghc-sha-prof
, libghc-http-prof
, libghc-hstringtemplate-prof
, libghc-recaptcha-prof
, libghc-filestore-prof
, libghc-zlib-prof
, libghc-url-prof
, libghc-happstack-server-prof
, libghc-base64-bytestring-prof
, libghc-xml-prof
, libghc-hslogger-prof
, libghc-configfile-prof
, libghc-feed-prof
, libghc-xss-sanitize-prof
, libghc-tagsoup-prof
, libghc-blaze-html-prof
, libghc-json-prof
, libghc-ghc-paths-prof
, libghc-safe-prof
, libghc-uri-prof
, libghc-split-prof
, libghc-hoauth2-prof
, libghc-http-conduit-prof
, libghc-http-client-tls-prof
, libghc-aeson-prof
, libghc-uuid-prof
Build-Depends-Indep: ghc-doc
# -doc dependencies
, libghc-parsec3-doc
, libghc-pretty-doc
, libghc-pandoc-doc
, libghc-pandoc-types-doc
, libghc-mtl-doc
, libghc-highlighting-kate-doc
, libghc-text-doc
, libghc-random-doc
, libghc-network-doc
, libghc-network-uri-doc
, libghc-utf8-string-doc
, libghc-sha-doc
, libghc-http-doc
, libghc-hstringtemplate-doc
, libghc-recaptcha-doc
, libghc-filestore-doc
, libghc-zlib-doc
, libghc-url-doc
, libghc-happstack-server-doc
, libghc-base64-bytestring-doc
, libghc-xml-doc
, libghc-hslogger-doc
, libghc-configfile-doc
, libghc-feed-doc
, libghc-xss-sanitize-doc
, libghc-tagsoup-doc
, libghc-blaze-html-doc
, libghc-json-doc
, libghc-ghc-paths-doc
, libghc-safe-doc
, libghc-uri-doc
, libghc-split-doc
, libghc-hoauth2-doc
, libghc-http-conduit-doc
, libghc-http-client-tls-doc
, libghc-aeson-doc
, libghc-uuid-doc
ghc-prof,
libghc-ghc-paths-dev,
libghc-ghc-paths-prof,
libghc-pandoc-dev (>= 1.12.4),
libghc-pandoc-dev (<< 1.16),
libghc-pandoc-prof,
libghc-pandoc-types-dev (>= 1.12.3),
libghc-pandoc-types-dev (<< 1.13),
libghc-pandoc-types-prof,
libghc-safe-dev,
libghc-safe-prof,
libghc-configfile-dev (>= 1),
libghc-configfile-dev (<< 1.2),
libghc-hstringtemplate-dev (>= 0.6),
libghc-hstringtemplate-dev (<< 0.9),
libghc-http-dev (>= 1:4000.0),
libghc-http-dev (<< 1:4000.3),
libghc-sha-dev (>> 1),
libghc-sha-dev (<< 1.7),
libghc-aeson-dev (>= 0.7),
libghc-aeson-dev (<< 0.10),
libghc-base64-bytestring-dev (>= 0.1),
libghc-base64-bytestring-dev (<< 1.1),
libghc-blaze-html-dev (>= 0.4),
libghc-blaze-html-dev (<< 0.9),
libghc-feed-dev (>= 0.3.6),
libghc-feed-dev (<< 0.4),
libghc-filestore-dev (>= 0.6),
libghc-filestore-dev (<< 0.7),
libghc-happstack-server-dev (>= 7.0),
libghc-happstack-server-dev (<< 7.5),
libghc-highlighting-kate-dev (>= 0.5.0.1),
libghc-highlighting-kate-dev (<< 0.7),
libghc-hoauth2-dev (>= 0.4.2),
libghc-hoauth2-dev (<< 0.5),
libghc-hslogger-dev (>= 1),
libghc-hslogger-dev (<< 1.3),
libghc-http-client-tls-dev (>= 0.2.2),
libghc-http-client-tls-dev (<< 0.3),
libghc-http-conduit-dev (>= 2.1.4),
libghc-http-conduit-dev (<< 2.2),
libghc-json-dev (>= 0.4),
libghc-json-dev (<< 0.10),
libghc-mtl-dev,
libghc-network-dev (>= 2.6),
libghc-network-uri-dev (>= 2.6),
libghc-network-uri-dev (<< 2.7),
libghc-old-locale-dev (>= 1),
libghc-old-time-dev,
libghc-parsec3-dev,
libghc-random-dev,
libghc-recaptcha-dev (>= 0.1),
libghc-split-dev,
libghc-syb-dev,
libghc-tagsoup-dev (>= 0.13),
libghc-tagsoup-dev (<< 0.14),
libghc-text-dev,
libghc-uri-dev (>= 0.1),
libghc-uri-dev (<< 0.2),
libghc-url-dev (>= 2.1),
libghc-url-dev (<< 2.2),
libghc-utf8-string-dev (>= 0.3),
libghc-utf8-string-dev (<< 1.1),
libghc-uuid-dev (>= 1.3),
libghc-uuid-dev (<< 1.4),
libghc-xml-dev (>= 1.3.5),
libghc-xss-sanitize-dev (>= 0.3),
libghc-xss-sanitize-dev (<< 0.4),
libghc-zlib-dev (>= 0.5),
libghc-zlib-dev (<< 0.7),
Build-Depends-Indep: ghc-doc,
libghc-ghc-paths-doc,
libghc-pandoc-doc,
libghc-pandoc-types-doc,
libghc-safe-doc,
Standards-Version: 3.9.6
Homepage: http://gitit.net/
Vcs-Darcs: http://darcs.debian.org/pkg-haskell/gitit
......@@ -186,14 +117,13 @@ X-Description: Wiki engine backed by a git or darcs filestore
Package: gitit
Architecture: any
Depends:
${haskell:Extra-Depends},
Section: web
Depends: ${haskell:Extra-Depends},
${misc:Depends},
${shlibs:Depends},
libghc-gitit-data (= ${source:Version}),
git | darcs | mercurial
Recommends: mime-support
Section: web
git | darcs | mercurial,
Recommends: mime-support,
Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
${haskell:LongDescription}
.
......@@ -201,15 +131,14 @@ Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
Package: libghc-gitit-dev
Architecture: any
Depends:
${haskell:Depends},
Depends: ${haskell:Depends},
${haskell:Extra-Depends},
${misc:Depends},
${shlibs:Depends},
libghc-gitit-data (= ${source:Version})
Suggests: ${haskell:Suggests}
Recommends: ${haskell:Recommends}
Provides: ${haskell:Provides}
libghc-gitit-data (= ${source:Version}),
Recommends: ${haskell:Recommends},
Suggests: ${haskell:Suggests},
Provides: ${haskell:Provides},
Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
${haskell:LongDescription}
.
......@@ -219,23 +148,22 @@ Package: libghc-gitit-prof
Architecture: any
Depends: ${haskell:Depends},
${shlibs:Depends},
${misc:Depends}
Suggests: ${haskell:Suggests}
Recommends: ${haskell:Recommends}
Provides: ${haskell:Provides}
${misc:Depends},
Recommends: ${haskell:Recommends},
Suggests: ${haskell:Suggests},
Provides: ${haskell:Provides},
Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
${haskell:LongDescription}
.
${haskell:Blurb}
Package: libghc-gitit-doc
Section: doc
Architecture: all
Depends:
${haskell:Depends},
${misc:Depends}
Suggests: ${haskell:Suggests}
Recommends: ${haskell:Recommends}
Section: doc
Depends: ${haskell:Depends},
${misc:Depends},
Recommends: ${haskell:Recommends},
Suggests: ${haskell:Suggests},
Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
${haskell:LongDescription}
.
......@@ -243,11 +171,11 @@ Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
Package: libghc-gitit-data
Architecture: all
Depends: ${misc:Depends}
Suggests: ${haskell:Suggests}
Recommends: ${haskell:Recommends}
Breaks: gitit (<< 0.10.6.3+dfsg-1)
Replaces: gitit (<< 0.10.6.3+dfsg-1)
Depends: ${misc:Depends},
Recommends: ${haskell:Recommends},
Suggests: ${haskell:Suggests},
Breaks: gitit (<< 0.10.6.3+dfsg-1),
Replaces: gitit (<< 0.10.6.3+dfsg-1),
Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
${haskell:LongDescription}
.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment