Commit 8a50a9d4 authored by Tobias Quathamer's avatar Tobias Quathamer

Prepare release 3.7

parent 87e85a2e
iso-codes trunk
---------------
UNRELEASED
iso-codes 3.7
-------------
Tobias Quathamer <toddy@debian.org>
Sun, 8 March 2009
[ General ]
* Use a Perl script for a complete check of valid UTF-8 text in po files
......
......@@ -159,7 +159,8 @@ pkgconfig_DATA = iso-codes.pc
EXTRA_DIST = \
LICENSE \
rules.make \
iso2pot.py
iso2pot.py \
check_valid_utf8.pl
DISTCLEANFILES = $(pkgconfig_DATA)
all: all-recursive
......
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
# Generated by GNU Autoconf 2.61 for ISO Codes 3.6.
# Generated by GNU Autoconf 2.61 for ISO Codes 3.7.
#
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
# 2002, 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
......@@ -572,8 +572,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
# Identity of this package.
PACKAGE_NAME='ISO Codes'
PACKAGE_TARNAME='iso-codes'
PACKAGE_VERSION='3.6'
PACKAGE_STRING='ISO Codes 3.6'
PACKAGE_VERSION='3.7'
PACKAGE_STRING='ISO Codes 3.7'
PACKAGE_BUGREPORT=''
ac_subst_vars='SHELL
......@@ -1151,7 +1151,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
\`configure' configures ISO Codes 3.6 to adapt to many kinds of systems.
\`configure' configures ISO Codes 3.7 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
......@@ -1217,7 +1217,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
short | recursive ) echo "Configuration of ISO Codes 3.6:";;
short | recursive ) echo "Configuration of ISO Codes 3.7:";;
esac
cat <<\_ACEOF
......@@ -1287,7 +1287,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
ISO Codes configure 3.6
ISO Codes configure 3.7
generated by GNU Autoconf 2.61
Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
......@@ -1301,7 +1301,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
It was created by ISO Codes $as_me 3.6, which was
It was created by ISO Codes $as_me 3.7, which was
generated by GNU Autoconf 2.61. Invocation command line was
$ $0 $@
......@@ -1992,7 +1992,7 @@ fi
# Define the identity of the package.
PACKAGE='iso-codes'
VERSION='3.6'
VERSION='3.7'
cat >>confdefs.h <<_ACEOF
......@@ -2806,7 +2806,7 @@ exec 6>&1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
This file was extended by ISO Codes $as_me 3.6, which was
This file was extended by ISO Codes $as_me 3.7, which was
generated by GNU Autoconf 2.61. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
......@@ -2849,7 +2849,7 @@ Report bugs to <bug-autoconf@gnu.org>."
_ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
ISO Codes config.status 3.6
ISO Codes config.status 3.7
configured by $0, generated by GNU Autoconf 2.61,
with options \\"`echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`\\"
......
......@@ -14,7 +14,7 @@ dnl You should have received a copy of the GNU General Public License along
dnl with this program; if not, write to the Free Software Foundation, Inc.,
dnl 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
AC_INIT([ISO Codes],[3.6],[],[iso-codes])
AC_INIT([ISO Codes],[3.7],[],[iso-codes])
dnl FIXME debug why this doesn't work; it substs an '' for VERSION
dnl until then, use PACKAGE_VERSION instead.
......
......@@ -340,7 +340,7 @@ check-local: check-content
.PHONY: check-content
check-content:
perl $(top_builddir)/check_valid_utf8.pl $(pofiles)
perl $(top_srcdir)/check_valid_utf8.pl $(pofiles)
# This target merges all po files with the current pot file,
# removes obsolete msgids and substitutes the Project-Id-Version
......
......@@ -498,7 +498,7 @@ check-local: check-content
.PHONY: check-content
check-content:
perl $(top_builddir)/check_valid_utf8.pl $(pofiles)
perl $(top_srcdir)/check_valid_utf8.pl $(pofiles)
# This target merges all po files with the current pot file,
# removes obsolete msgids and substitutes the Project-Id-Version
......
......@@ -340,7 +340,7 @@ check-local: check-content
.PHONY: check-content
check-content:
perl $(top_builddir)/check_valid_utf8.pl $(pofiles)
perl $(top_srcdir)/check_valid_utf8.pl $(pofiles)
# This target merges all po files with the current pot file,
# removes obsolete msgids and substitutes the Project-Id-Version
......
......@@ -340,7 +340,7 @@ check-local: check-content
.PHONY: check-content
check-content:
perl $(top_builddir)/check_valid_utf8.pl $(pofiles)
perl $(top_srcdir)/check_valid_utf8.pl $(pofiles)
# This target merges all po files with the current pot file,
# removes obsolete msgids and substitutes the Project-Id-Version
......
......@@ -526,7 +526,7 @@ check-local: check-content
.PHONY: check-content
check-content:
perl $(top_builddir)/check_valid_utf8.pl $(pofiles)
perl $(top_srcdir)/check_valid_utf8.pl $(pofiles)
# This target merges all po files with the current pot file,
# removes obsolete msgids and substitutes the Project-Id-Version
......
......@@ -340,7 +340,7 @@ check-local: check-content
.PHONY: check-content
check-content:
perl $(top_builddir)/check_valid_utf8.pl $(pofiles)
perl $(top_srcdir)/check_valid_utf8.pl $(pofiles)
# This target merges all po files with the current pot file,
# removes obsolete msgids and substitutes the Project-Id-Version
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment