Commit f9a3992f authored by Markus Koschany's avatar Markus Koschany

Drop enable-activemq-jdbc-store-module.patch

parent 14b3445d
From: Michail Bachmann <michail.bachmann@cms.hu-berlin.de>
Date: Tue, 24 Apr 2018 12:45:18 +0200
Subject: enable activemq jdbc store module
commons-dbcp2 is not available in Debian, so fallback to commons-dbcp.
Bug-Debian: https://bugs.debian.org/895028
---
activemq-jdbc-store/pom.xml | 10 ++++++++++
pom.xml | 14 ++++++++++++++
2 files changed, 24 insertions(+)
diff --git a/activemq-jdbc-store/pom.xml b/activemq-jdbc-store/pom.xml
index c0390d7..30ade33 100644
--- a/activemq-jdbc-store/pom.xml
+++ b/activemq-jdbc-store/pom.xml
@@ -49,6 +49,16 @@
<artifactId>activeio-core</artifactId>
<optional>true</optional>
</dependency>
+ <dependency>
+ <groupId>commons-dbcp</groupId>
+ <artifactId>commons-dbcp</artifactId>
+ <optional>true</optional>
+ </dependency>
+ <dependency>
+ <groupId>commons-pool</groupId>
+ <artifactId>commons-pool</artifactId>
+ <optional>true</optional>
+ </dependency>
<!-- =============================== -->
<!-- Testing Dependencies -->
diff --git a/pom.xml b/pom.xml
index db96209..9320b94 100644
--- a/pom.xml
+++ b/pom.xml
@@ -53,10 +53,12 @@
<commons-beanutils-version>1.9.3</commons-beanutils-version>
<commons-collections-version>3.2.2</commons-collections-version>
<commons-daemon-version>1.0.15</commons-daemon-version>
+ <commons-dbcp-version>1.4</commons-dbcp-version>
<commons-dbcp2-version>2.1.1</commons-dbcp2-version>
<commons-io-version>2.5</commons-io-version>
<commons-lang-version>2.6</commons-lang-version>
<commons-logging-version>1.2</commons-logging-version>
+ <commons-pool-version>1.6</commons-pool-version>
<commons-pool2-version>2.4.2</commons-pool2-version>
<commons-primitives-version>1.0</commons-primitives-version>
<commons-net-version>3.6</commons-net-version>
@@ -861,6 +863,18 @@
<version>${commons-pool2-version}</version>
</dependency>
+ <dependency>
+ <groupId>commons-dbcp</groupId>
+ <artifactId>commons-dbcp</artifactId>
+ <version>${commons-dbcp-version}</version>
+ </dependency>
+
+ <dependency>
+ <groupId>commons-pool</groupId>
+ <artifactId>commons-pool</artifactId>
+ <version>${commons-pool-version}</version>
+ </dependency>
+
<!-- Optional Journal Implementation -->
<!--
<dependency>
......@@ -2,4 +2,3 @@ init-debian-default-values.patch
activemq-spring.patch
activemq-client-jar.patch
disable-broker-test-dependency.patch
enable-activemq-jdbc-store-module.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment