Commit f3157f0f authored by Emmanuel Bourg's avatar Emmanuel Bourg

Require Java 8 or higher to run Ant

parent 8f2d06c4
......@@ -4,6 +4,7 @@ ant (1.10.3-1) UNRELEASED; urgency=medium
- Refreshed the patches
- Changed the source/target level to 1.8 when building Ant
- Build the new optional ant-xz module
- Require Java 8 or higher to run Ant
* Adjust the source/target level to 1.7 in anticipation of the 1.6 removal
in Java 11
* Added activation.jar to the build classpath to fix the empty ant-javamail
......
......@@ -32,7 +32,7 @@ Homepage: http://ant.apache.org
Package: ant
Architecture: all
Depends: default-jre-headless | java5-runtime-headless | java6-runtime-headless | java7-runtime-headless,
Depends: default-jre-headless (>= 2:1.8) | java8-runtime-headless,
${misc:Depends}
Recommends: ant-optional
Suggests: ant-doc, default-jdk | java-compiler | java-sdk
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment