...
 
Commits (3)
ant (1.10.5-2) unstable; urgency=medium
* Team upload.
* Lower the minimum required source/target level to 1.6 again.
This is acceptable for OpenJDK 11 but must be reverted for OpenJDK 12.
Thanks to Bdale Garbee for the report and patch. (Closes: #906785)
* Declare compliance with Debian Policy 4.2.1.
-- Markus Koschany <apo@debian.org> Mon, 27 Aug 2018 14:57:47 +0200
ant (1.10.5-1) unstable; urgency=medium
* Team upload.
......
......@@ -25,7 +25,7 @@ Build-Depends: antlr,
libxml-commons-resolver1.1-java (>= 1.2-7~),
libxz-java,
maven-repo-helper (>> 1.0)
Standards-Version: 4.1.5
Standards-Version: 4.2.1
Vcs-Git: https://salsa.debian.org/java-team/ant.git
Vcs-Browser: https://salsa.debian.org/java-team/ant
Homepage: http://ant.apache.org
......
......@@ -67,10 +67,10 @@ Forwarded: no
+class LanguageLevel {
+
+ /** The minimum language level supported by the current javac */
+ private static final String MIN_LEVEL = "7";
+ private static final String MIN_LEVEL = "6";
+
+ /** The list of language levels no longer supported by the current javac */
+ private static final List<String> UNSUPPORTED_LEVELS = Arrays.asList(new String[]{"1.1", "1.2", "1.3", "1.4", "1.5", "5", "1.6", "6"});
+ private static final List<String> UNSUPPORTED_LEVELS = Arrays.asList(new String[]{"1.1", "1.2", "1.3", "1.4", "1.5", "5"});
+
+ /** Detect if a Debian build is in process */
+ static boolean isDebianBuild() {
......