Commit ea18da28 authored by Emmanuel Bourg's avatar Emmanuel Bourg

Build with maven-debian-helper

Ignore the unstable BOBYQAOptimizer tests (Closes: #735792)
parent 0187783a
junit.jar=/usr/share/java/junit4.jar
# Ensure that source and target are 1.5
# For backwards compat on Java 7
ant.build.javac.source=1.5
ant.build.javac.target=1.5
commons-math3 (3.2-4) UNRELEASED; urgency=medium
commons-math3 (3.2-4) unstable; urgency=medium
* debian/control:
- Standards-Version updated to 3.9.5 (no changes)
* Build with maven-debian-helper
* Standards-Version updated to 3.9.5 (no changes)
* Switch to debhelper level 9
* Ignore the unstable BOBYQAOptimizer tests (Closes: #735792)
-- Emmanuel Bourg <ebourg@apache.org> Fri, 17 Jan 2014 22:16:36 +0100
-- Emmanuel Bourg <ebourg@apache.org> Sat, 18 Jan 2014 09:55:20 +0100
commons-math3 (3.2-3) unstable; urgency=low
......
......@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Uploaders: Emmanuel Bourg <ebourg@apache.org>
Build-Depends: default-jdk, ant, debhelper (>= 9), cdbs
Build-Depends-Indep: junit4, ant-optional, maven-repo-helper
Build-Depends-Indep: junit4, ant-optional, maven-debian-helper, libmaven-javadoc-plugin-java
Standards-Version: 3.9.5
Vcs-Svn: svn://anonscm.debian.org/pkg-java/trunk/commons-math3
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-java/trunk/commons-math3
......
RELEASE-NOTES.txt
target/api /usr/share/doc/libcommons-math3-java
target/apidocs/* /usr/share/doc/libcommons-math3-java/api
pom.xml --no-parent
# List of POM files for the package
# Format of this file is:
# <path to pom file> [option]*
# where option can be:
# --ignore: ignore this POM and its artifact if any
# --ignore-pom: don't install the POM. To use on POM files that are created
# temporarily for certain artifacts such as Javadoc jars. [mh_install, mh_installpoms]
# --no-parent: remove the <parent> tag from the POM
# --package=<package>: an alternative package to use when installing this POM
# and its artifact
# --has-package-version: to indicate that the original version of the POM is the same as the upstream part
# of the version for the package.
# --keep-elements=<elem1,elem2>: a list of XML elements to keep in the POM
# during a clean operation with mh_cleanpom or mh_installpom
# --artifact=<path>: path to the build artifact associated with this POM,
# it will be installed when using the command mh_install. [mh_install]
# --java-lib: install the jar into /usr/share/java to comply with Debian
# packaging guidelines
# --usj-name=<name>: name to use when installing the library in /usr/share/java
# --usj-version=<version>: version to use when installing the library in /usr/share/java
# --no-usj-versionless: don't install the versionless link in /usr/share/java
# --dest-jar=<path>: the destination for the real jar.
# It will be installed with mh_install. [mh_install]
# --classifier=<classifier>: Optional, the classifier for the jar. Empty by default.
# --site-xml=<location>: Optional, the location for site.xml if it needs to be installed.
# Empty by default. [mh_install]
#
pom.xml --has-package-version --java-lib --no-parent
org.apache.maven.plugins maven-assembly-plugin * * * *
org.apache.maven.plugins maven-changes-plugin * * * *
org.apache.maven.plugins maven-checkstyle-plugin * * * *
org.apache.maven.plugins maven-pmd-plugin * * * *
org.apache.maven.plugins maven-scm-publish-plugin * * * *
org.apache.rat apache-rat-plugin * * * *
org.codehaus.mojo clirr-maven-plugin * * * *
org.codehaus.mojo findbugs-maven-plugin * * * *
project.build.sourceEncoding=UTF-8
junit junit jar s/4\..*/4.x/
junit junit jar s/4\..*/4.x/ * *
Description: Ignore unstable BOBYQAOptimizer tests
Author: Emmanuel Bourg <ebourg@apache.org>
Bug: https://issues.apache.org/jira/browse/MATH-1057
--- a/src/test/java/org/apache/commons/math3/optim/nonlinear/scalar/noderiv/BOBYQAOptimizerTest.java
+++ b/src/test/java/org/apache/commons/math3/optim/nonlinear/scalar/noderiv/BOBYQAOptimizerTest.java
@@ -179,6 +179,7 @@
}
@Test
+ @Ignore
public void testDiffPow() {
double[] startPoint = point(DIM/2,1.0);
double[][] boundaries = null;
@@ -201,6 +202,7 @@
}
@Test
+ @Ignore
public void testAckley() {
double[] startPoint = point(DIM,0.1);
double[][] boundaries = null;
--- a/src/test/java/org/apache/commons/math3/optimization/direct/BOBYQAOptimizerTest.java
+++ b/src/test/java/org/apache/commons/math3/optimization/direct/BOBYQAOptimizerTest.java
@@ -178,6 +178,7 @@
}
@Test
+ @Ignore
public void testDiffPow() {
double[] startPoint = point(DIM/2,1.0);
double[][] boundaries = null;
@@ -200,6 +201,7 @@
}
@Test
+ @Ignore
public void testAckley() {
double[] startPoint = point(DIM,0.1);
double[][] boundaries = null;
Description: build.xml: don't run test directly after build
as per Java Policy: "Failing tests MUST not lead to a failing build."
Author: Damien Raude-Morvan <drazzib@drazzib.com>
Forwarded: not-needed
Origin: vendor
Last-Update: 2009-07-16
--- a/build.xml
+++ b/build.xml
@@ -255,7 +255,7 @@
<!-- ========== Create Jar ================================================ -->
- <target name="jar" depends="test" description="Create jar file">
+ <target name="jar" depends="compile" description="Create jar file">
<copy file="LICENSE.txt" tofile="${build.home}/classes/META-INF/LICENSE.txt"/>
<copy file="NOTICE.txt" tofile="${build.home}/classes/META-INF/NOTICE.txt"/>
Description: Fixes the version in the build file
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: not-needed
--- a/build.xml
+++ b/build.xml
@@ -52,7 +52,7 @@
<property name="component.title" value="Commons MATH"/>
<!-- The current version number of this component -->
- <property name="component.version" value="3.1-SNAPSHOT"/>
+ <property name="component.version" value="3.2"/>
<!-- The base directory for component sources -->
<property name="source.home" value="src/main/java"/>
02_no_tests_on_build.diff
03_fix_version.diff
01_ignore_unstable_tests.diff
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/ant.mk
include /usr/share/cdbs/1/class/maven.mk
JAVA_HOME := /usr/lib/jvm/default-java
DEB_JARS := ant-junit ant-junit4
ANT_ARGS := -Dskip.download=true
JAVA_HOME := /usr/lib/jvm/default-java
PACKAGE := $(DEB_SOURCE_PACKAGE)
DEB_ANT_CLEAN_TARGET := clean
DEB_ANT_BUILD_TARGET := jar javadoc
DEB_ANT_CHECK_TARGET := test
# Per Debian Java Policy, install a versioned JAR and an unversioned symlink
binary-post-install/lib$(PACKAGE)-java::
mh_installpoms -plib$(PACKAGE)-java
mh_installjar -plib$(PACKAGE)-java -l pom.xml target/commons-math-$(DEB_UPSTREAM_VERSION).jar
install/lib$(PACKAGE)-java-doc::
mv target/apidocs target/api
clean::
mh_clean
DEB_INSTALL_CHANGELOGS_ALL := RELEASE-NOTES.txt
get-orig-source:
uscan --force-download --rename
uscan --download-version $(DEB_UPSTREAM_VERSION) --force-download --rename
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment