Commit 4f02cb77 authored by Markus Koschany's avatar Markus Koschany

Add manifest patch and fix Manifest attribute.

parent f39580db
......@@ -2,6 +2,8 @@ From: Markus Koschany <apo@debian.org>
Date: Sun, 30 Sep 2018 21:42:15 +0200
Subject: build
Avoid build-depending on Git.
Forwarded: not-needed
---
build.xml | 22 +---------------------
1 file changed, 1 insertion(+), 21 deletions(-)
......
......@@ -8,7 +8,7 @@ Fixes the compatibility with the version of JFlex in Debian
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/build.xml b/build.xml
index d464a96..d3dba25 100644
index d464a96..3a74762 100644
--- a/build.xml
+++ b/build.xml
@@ -45,14 +45,14 @@
......
From: Markus Koschany <apo@debian.org>
Date: Mon, 1 Oct 2018 14:26:11 +0200
Subject: manifest
Fix compatibility with Debian's cup version and use 0.11b version.
---
build.xml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/build.xml b/build.xml
index 3a74762..b513fa9 100644
--- a/build.xml
+++ b/build.xml
@@ -70,7 +70,7 @@
<jar jarfile="${dist}/java-cup-11b.jar" basedir="${classes}">
<manifest>
<attribute name="Main-Class" value="java_cup/Main" />
- <attribute name="Class-Path" value="java-cup-11b-runtime.jar" />
+ <attribute name="Class-Path" value="java-cup-0.11b-runtime.jar" />
</manifest>
</jar>
<jar jarfile="${dist}/java-cup-11b-runtime.jar" basedir="${classes}" includes="java_cup/runtime/*">
build.patch
jflex-1.6.1.patch
manifest.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment