diff --git a/debian/changelog b/debian/changelog
index 4efd37f760788aac3ff82635bfe6263031c6ab39..715f3a58ea6cb39834e62e027fb1e0ac410152a1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
 javahelp2 (2.0.05.ds1-10) UNRELEASED; urgency=medium
 
   * Team upload.
+  * Depend on lib{servlet,jsp}-api-java instead of libservlet3.1-java
   * Standards-Version updated to 4.6.1
   * Switch to debhelper level 13
   * Use salsa.debian.org Vcs-* URLs
diff --git a/debian/control b/debian/control
index 00712f52af3d341b7f7110799aa161f63e4cf041..184fc1b2f6ddd93e7cfca836cc52749047a33bad 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,8 @@ Build-Depends:
  debhelper-compat (= 13),
  default-jdk,
  imagemagick,
- libservlet3.1-java,
+ libjsp-api-java,
+ libservlet-api-java,
  maven-repo-helper
 Standards-Version: 4.6.1
 Vcs-Git: https://salsa.debian.org/java-team/javahelp2.git
diff --git a/debian/rules b/debian/rules
index 768ccb39d92b8980ec53c12a4519c5a560b01cfb..e8f79cff6cbc8f2c9a2acf26e1c9fea3d759e3ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,8 +25,8 @@ build/$(p_jh):: stamp-build-$(p_jh)
 stamp-build-$(p_jh):
 	#Create symlink to required jars
 	mkdir -p $(DEB_SRCDIR)/javahelp_nbproject/lib
-	ln -s -f /usr/share/java/servlet-api-3.1.jar $(DEB_SRCDIR)/javahelp_nbproject/lib/servlet-api.jar
-	ln -s -f /usr/share/java/jsp-api-2.3.jar $(DEB_SRCDIR)/javahelp_nbproject/lib/jsp-api.jar
+	ln -s -f /usr/share/java/servlet-api.jar $(DEB_SRCDIR)/javahelp_nbproject/lib/servlet-api.jar
+	ln -s -f /usr/share/java/jsp-api.jar     $(DEB_SRCDIR)/javahelp_nbproject/lib/jsp-api.jar
 	#Remove class uncompilable without JDIC
 	rm -f $(DEB_SRCDIR)/jhMaster/JavaHelp/src/new/javax/help/plaf/basic/BasicNativeContentViewerUI.java
 	#Build javahelp target 'release' is for jars, target 'javadoc' is for javadoc