diff --git a/debian/changelog b/debian/changelog
index 9748108d97bf58e316656f7846c90635dc34173c..c91298cecdae950ea2b51d2f442029c8d2c379c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,12 @@
 javahelp2 (2.0.05.ds1-8) UNRELEASED; urgency=medium
 
   * Team upload.
+
+  [ Reiner Herrmann ]
+  * Removed the timestamp from the PNG files to make the build reproducible.
+    (Closes: #779056)
+
+  [ Emmanuel Bourg ]
   * Moved the package to Git
   * Standards-Version updated to 3.9.6 (no changes)
 
diff --git a/debian/rules b/debian/rules
index 5dde641e5de1dd342de750872040a61bfe9b3b5d..7d3230c6f62ad08825d8bcddcf71524cfa95ca30 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,7 +15,7 @@ makebuilddir/$(p_jh)::
 	cd $(DEB_SRCDIR)/debian/icons/; \
 	for file in *.xpm; do \
 		fileTarget=`echo $$file|sed -e 's|.xpm|.png|g'`; \
-		convert $(DEB_SRCDIR)/$$file $(CURDIR)/jhMaster/JavaHelp/src/new/javax/help/plaf/basic/images/$$fileTarget; \
+		convert $(DEB_SRCDIR)/$$file +set date:create +set date:modify -define png:exclude-chunk=time $(CURDIR)/jhMaster/JavaHelp/src/new/javax/help/plaf/basic/images/$$fileTarget; \
 	done
 
 build/$(p_jh):: stamp-build-$(p_jh)