changelog 6.71 KB
Newer Older
1 2 3 4 5 6 7 8 9 10 11
libreadline-java (0.8.0.1-8) unstable; urgency=low

  * Change from using gcjh to gjavah, since gcjh has been removed
    (closes: #423992).
  * Switched from setting $DH_COMPAT to using debian/compat instead.
  * Removed blank lines from the end of the doc-base file, which seem to be
    confusing lintian.
  * Bump standards-version to 3.7.2.2 (no changes required).

 -- Ben Burton <bab@debian.org>  Sat, 19 May 2007 15:37:47 +1000

12 13 14 15 16 17 18
libreadline-java (0.8.0.1-7.1) unstable; urgency=low

  * Non-maintainer upload.
  * Drop Build-Depends on libgcj-dev. (Closes: #359737)

 -- Mohammed Adnène Trojette <adn+deb@diwi.org>  Sat,  5 Aug 2006 20:11:01 +0200

19 20 21 22 23 24 25
libreadline-java (0.8.0.1-7) unstable; urgency=low

  * Build-depends on java-gcj-compat-dev, so that the recently relocated
    jni.h can be found (closes: #371060).

 -- Ben Burton <bab@debian.org>  Thu,  8 Jun 2006 08:19:38 +1000

26 27 28 29 30 31 32 33 34
libreadline-java (0.8.0.1-6) unstable; urgency=low

  * Rebuilt using gcj-4.1; updated build scripts to reflect the new locations
    of JNI headers, updated build-depends accordingly.
  * Switched to DH_COMPAT=5 and updated build-depends accordingly.
  * Updated standards-version to 3.7.2.0 (no changes required).

 -- Ben Burton <bab@debian.org>  Wed,  7 Jun 2006 07:49:43 +1000

35 36 37 38 39 40 41 42
libreadline-java (0.8.0.1-5) unstable; urgency=low

  * Rebuilt against libreadline5 (closes: #326334).  Build-depends on
    libreadline4-dev changed to (libreadline5-dev | libreadline-dev).
  * Bumped standards-version to 3.6.2.1 (no changes required).

 -- Ben Burton <bab@debian.org>  Sat,  3 Sep 2005 13:14:46 +1000

43 44 45 46 47 48 49 50 51 52 53 54 55 56
libreadline-java (0.8.0.1-4) unstable; urgency=low

  * Now that libgcj-dev is a real package that depends on a compatible gcj,
    we can change the build-depends to use gcj and libgcj-dev
    (instead of gcj-3.3 and libgcj4-dev) without risk of unwanted version
    skew.  This allows libreadline-java to be built on archs such as ppc64
    that only support gcc-4.0 (closes: #300353).
  * Use a versioned build-depends on libgcj-dev to make sure we get the real
    libgcj-dev and not the virtual one.  Add a similar version on the gcj
    build-depends also.
  * Add a real alternative (w3m) to www-browser for libreadline-java-doc.

 -- Ben Burton <bab@debian.org>  Tue, 26 Apr 2005 07:48:31 +1000

57 58 59 60 61 62 63 64 65
libreadline-java (0.8.0.1-3) unstable; urgency=low

  * Allow libreadline-java to depend on either java1-runtime or java2-runtime,
    since it doesn't use any deprecated java1 methods (closes: #297552).
  * Build-depend on gcj-3.3 instead of gcj, so we don't get a version skew
    between gcj and libgcj4-dev when the default gcj is upgraded.

 -- Ben Burton <bab@debian.org>  Fri, 18 Mar 2005 07:53:04 +1100

66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120
libreadline-java (0.8.0.1-2) unstable; urgency=low

  * Added build-depends on libgcj4-dev, which gcj no longer drags in on its
    own (closes: #240264).
  * Bumped standards-version to 3.6.1.

 -- Ben Burton <bab@debian.org>  Fri,  2 Apr 2004 23:07:54 +1000

libreadline-java (0.8.0.1-1) unstable; urgency=low

  * Added changes from development CVS to implement getVar() and setVar(),
    which are required for proper integration with jython (see #184838
    for details).  Also enhanced these routines for compatibility with
    BSD editline.
  * Bumped the upstream source version to make it clear that new
    functionality has been added.

 -- Ben Burton <bab@debian.org>  Wed, 27 Aug 2003 13:50:38 +1000

libreadline-java (0.8.0-2) unstable; urgency=low

  * Uses default gcj, not gcj-3.2 (closes: #201454).
  * Bumped standards-version to 3.6.0.
  * Installs JNI module in /usr/lib/jni according to java policy.

 -- Ben Burton <bab@debian.org>  Tue, 19 Aug 2003 16:42:36 -0500

libreadline-java (0.8.0-1) unstable; urgency=low

  * New upstream release.
  * Added defaults for virtual package dependencies.
  * Minor changes for command-line in README.test.
  * New maintainer email address.
  * Bumped standards-version to 3.5.8.

 -- Ben Burton <bab@debian.org>  Wed, 29 Jan 2003 12:31:02 +1100

libreadline-java (0.7.3-2) unstable; urgency=low

  * Implement getHistory() manually under Editline instead of using the
    underlying history_list() call which libedit does not support
    (closes: Bug#166091).

 -- Ben Burton <benb@acm.org>  Thu, 24 Oct 2002 09:29:29 +1000

libreadline-java (0.7.3-1) unstable; urgency=high

  * New upstream release.
  * Now builds using gcj-3.2 since this is available for enough architectures.
  * Updated to reflect latest java policy.
  * Moved examples from libreadline-java to libreadline-java-doc.
  * Bumped standards-version to 3.5.7.

 -- Ben Burton <benb@acm.org>  Thu,  3 Oct 2002 16:36:21 +1000

121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196
libreadline-java (0.7.0-2) unstable; urgency=high

  * Updated build procedure to reflect relocation of kaffe bootstrap classes.
    Now either location should be fine.
  * Modified build-depends to ensure we're not building under a broken jikes.

 -- Ben Burton <benb@acm.org>  Fri, 19 Apr 2002 20:17:45 +1000

libreadline-java (0.7.0-1) unstable; urgency=low

  * New upstream release.

 -- Ben Burton <benb@acm.org>  Mon, 11 Feb 2002 14:47:23 +1100

libreadline-java (0.6-1) unstable; urgency=low

  * New upstream release.
  * Merged libeditline-java and libreadline-java into a single package.

 -- Ben Burton <benb@acm.org>  Sun,  9 Dec 2001 10:11:21 -0600

libreadline-java (0.5-8) unstable; urgency=low

  * Build uses gcj over kaffe when both are available.

 -- Ben Burton <benb@acm.org>  Wed,  7 Nov 2001 19:40:05 -0600

libreadline-java (0.5-7) unstable; urgency=low

  * Changed package name to conform to new java policy.
  * Now builds with either gcj or kaffe since neither compiler is
    provided for all architectures.

 -- Ben Burton <benb@acm.org>  Sat, 27 Oct 2001 13:24:22 -0500

lib-readline-java (0.5-6) unstable; urgency=low

  * Builds using gcj instead of jikes and kaffe.

 -- Ben Burton <benb@acm.org>  Sat, 13 Oct 2001 18:39:43 -0500

lib-readline-java (0.5-5) unstable; urgency=low

  * Split API docs into separate package lib-readline-java-doc that
    lib-editline-java can refer to also.
  * Tidied up in debian/.

 -- Ben Burton <benb@acm.org>  Fri, 31 Aug 2001 15:25:31 -0500

lib-readline-java (0.5-4) unstable; urgency=low

  * Cleaned up debian/rules.

 -- Ben Burton <benb@acm.org>  Mon, 13 Aug 2001 15:27:09 +1000

lib-readline-java (0.5-3) unstable; urgency=low

  * Upped standards-version to 3.5.6.

 -- Ben Burton <benb@acm.org>  Sun,  5 Aug 2001 10:07:00 +1000

lib-readline-java (0.5-2) unstable; urgency=low

  * Updated copyright file to note that the underlying libreadline is GPLed.

 -- Ben Burton <benb@acm.org>  Mon,  2 Jul 2001 10:39:07 -0500

lib-readline-java (0.5-1) unstable; urgency=low

  * Initial Release (closes: Bug#102928).

 -- Ben Burton <benb@acm.org>  Sat, 30 Jun 2001 18:03:06 -0500

Local variables:
mode: debian-changelog
End: