...
 
Commits (4)
netbeans (10.0-2) UNRELEASED; urgency=medium
* Add Unsafe.patch
* Fix another NullPointerException by adding a symlink to asm-all.jar (ide)
* Fix broken subversion support.
-- Markus Koschany <apo@debian.org> Sat, 26 Jan 2019 18:43:03 +0100
netbeans (10.0-2) unstable; urgency=medium
* Replace NoJavacHelper.patch with Unsafe.patch which is much better.
* Fix broken subversion support by symlinking all necessary system jars to
the ide cluster.
* Remove netbeans-slf4j.dummy.patch again.
* Add nb-javac.patch. The nb-javac module is not properly detected. This
patch adds the necessary jar files to the Class-Path. However now there is
an Unexpected Exception, a sealing violation. It appears to be harmless
but the notification at startup is irritating.
-- Markus Koschany <apo@debian.org> Sun, 27 Jan 2019 23:15:32 +0100
netbeans (10.0-1) unstable; urgency=medium
......
......@@ -9,7 +9,6 @@ Build-Depends:
ant,
ant-optional,
antlr3 (>= 3.5.2),
libantlr4-runtime-java,
debhelper (>= 11),
default-jdk,
icnsutils,
......@@ -19,11 +18,10 @@ Build-Depends:
junit,
junit4,
libactivation-java,
libbyte-buddy-java,
libantlr4-runtime-java,
libbeansbinding-java,
libguava-java,
libgoogle-gson-java (>= 2.8.5-3),
libbindex-java,
libbyte-buddy-java,
libbytelist-java,
libcglib-java (>= 3.0),
libcommons-codec-java,
......@@ -36,8 +34,9 @@ Build-Depends:
libequinox-osgi-java (>= 3.9.1-4),
libfelix-framework-java,
libfelix-main-java,
libjsr305-java,
libfreemarker-java,
libgoogle-gson-java (>= 2.8.5-3),
libguava-java,
libhamcrest-java,
libhtml5parser-java,
libhttpclient-java,
......@@ -55,6 +54,7 @@ Build-Depends:
libjsch-agent-proxy-java (>= 0.0.8),
libjsch-java,
libjson-simple-java,
libjsr305-java,
libjvyamlb-java,
libjzlib-java,
liblucene3-java,
......@@ -78,7 +78,7 @@ Build-Depends:
maven-repo-helper,
testng
Standards-Version: 4.3.0
Homepage: http://netbeans.org/
Homepage: https://netbeans.org/
Vcs-Browser: https://salsa.debian.org/java-team/netbeans
Vcs-Git: https://salsa.debian.org/java-team/netbeans.git
......@@ -124,8 +124,8 @@ Depends:
libhttpclient-java,
libicu4j-4.4-java,
libini4j-java,
libjaxb-java,
libjaxb-api-java,
libjaxb-java,
libjgit-java,
libjsch-agent-proxy-java (>= 0.0.8),
libjsch-java,
......
......@@ -2,6 +2,9 @@ From: Markus Koschany <apo@debian.org>
Date: Sat, 26 Jan 2019 23:12:18 +0100
Subject: nb-javac
The nb-javac module is not properly detected by Netbeans. Only when we add
these jar files from libnb-javaparser-java to the Class-Path it works. However
now there is another problem, a security exception: sealing violation
---
java/libs.javacapi/manifest.mf | 1 +
java/libs.javacimpl/manifest.mf | 1 +
......