Import Debian changes 1.6.0-1

node-babel-preset-env (1.6.0-1) UNRELEASED; urgency=low

  * Initial release (Closes: #nnnn)
  *
parent fbd5e08d
node-babel-preset-env (1.6.0-1) UNRELEASED; urgency=low
* Initial release (Closes: #nnnn)
*
-- Pirate Praveen <praveen@debian.org> Wed, 20 Sep 2017 12:02:54 +0530
Source: node-babel-preset-env
Section: web
Priority: optional
Maintainer: Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Uploaders: Pirate Praveen <praveen@debian.org>
Build-Depends:
debhelper (>= 9)
, dh-buildinfo
, nodejs
Standards-Version: 4.0.0
Homepage: https://babeljs.io/
Vcs-Git: https://anonscm.debian.org/git/pkg-javascript/node-babel-preset-env.git
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-javascript/node-babel-preset-env.git
Package: node-babel-preset-env
Architecture: all
Depends:
${misc:Depends}
, nodejs
, node-babel-plugin-transform-es2015-modules-systemjs (>= 6.23.0)
, node-babel-plugin-transform-es2015-computed-properties (>= 6.22.0)
, node-babel-plugin-transform-es2015-parameters (>= 6.23.0)
, node-babel-plugin-transform-es2015-literals (>= 6.22.0)
, node-semver (>= 5.3.0)
, node-browserslist (>= 2.1.2)
, node-babel-plugin-transform-es2015-modules-umd (>= 6.23.0)
, node-babel-plugin-transform-exponentiation-operator (>= 6.22.0)
, node-babel-plugin-transform-es2015-modules-amd (>= 6.22.0)
, node-babel-plugin-transform-es2015-unicode-regex (>= 6.22.0)
, node-babel-plugin-transform-es2015-duplicate-keys (>= 6.22.0)
, node-babel-plugin-transform-es2015-shorthand-properties (>= 6.22.0)
, node-babel-plugin-transform-es2015-classes (>= 6.23.0)
, node-babel-plugin-transform-async-to-generator (>= 6.22.0)
, node-babel-plugin-transform-es2015-typeof-symbol (>= 6.23.0)
, node-babel-plugin-transform-es2015-block-scoping (>= 6.23.0)
, node-babel-plugin-transform-regenerator (>= 6.22.0)
, node-babel-plugin-transform-es2015-block-scoped-functions (>= 6.22.0)
, node-babel-plugin-check-es2015-constants (>= 6.22.0)
, node-babel-plugin-syntax-trailing-function-commas (>= 6.22.0)
, node-babel-plugin-transform-es2015-template-literals (>= 6.22.0)
, node-babel-plugin-transform-es2015-sticky-regex (>= 6.22.0)
, node-babel-plugin-transform-es2015-arrow-functions (>= 6.22.0)
, node-babel-plugin-transform-es2015-for-of (>= 6.23.0)
, node-babel-plugin-transform-es2015-modules-commonjs (>= 6.23.0)
, node-invariant (>= 2.2.2)
, node-babel-plugin-transform-es2015-destructuring (>= 6.23.0)
, node-babel-plugin-transform-es2015-function-name (>= 6.22.0)
, node-babel-plugin-transform-es2015-spread (>= 6.22.0)
, node-babel-plugin-transform-es2015-object-super (>= 6.22.0)
Description: FIX_ME write the Debian package description
Write the short and long descriptions for the Debian package as
explained in the Developer's Reference, §6.2.1 – §6.2.3.
.
You can start with the short upstream package description,
“A Babel preset for each environment.”.
.
Be aware that most upstream package descriptions are not written to
conform with Debian package guidelines. You need to explain the role
of this package for a Debian audience.
.
Node.js is an event-based server-side JavaScript engine.
Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: babel-preset-env
Upstream-Contact: https://github.com/babel/babel-preset-env/issues
Source: https://babeljs.io/
Files: *
Copyright: 2017 Henry Zhu <hi@henryzoo.com>
License: Expat
Files: debian/*
Copyright: 2017 Pirate Praveen <praveen@debian.org>
License: Expat
License: Expat
Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated documentation files
(the "Software"), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software,
and to permit persons to whom the Software is furnished to do so,
subject to the following conditions:
.
The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.
.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
README.md
package.json usr/lib/nodejs/babel-preset-env/
CONTRIBUTING.md usr/lib/nodejs/babel-preset-env/
lib usr/lib/nodejs/babel-preset-env/
data usr/lib/nodejs/babel-preset-env/
#!/usr/bin/make -f
# -*- makefile -*-
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
%:
dh $@
#override_dh_auto_build:
#override_dh_auto_test:
Tests: require
Depends: node-babel-preset-env
#!/bin/sh
set -e
nodejs -e "require('babel-preset-env');"
version=3
opts=\
dversionmangle=s/\+(debian|dfsg|ds|deb)(\.\d+)?$//,\
filenamemangle=s/.*\/v?([\d\.-]+)\.tar\.gz/node-babel-preset-env-$1.tar.gz/ \
https://github.com/babel/babel-preset-env/tags .*/archive/v?([\d\.]+).tar.gz
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment