Commit 20240cbd authored by Xavier Guimard's avatar Xavier Guimard

Merge branch 'buster'

parents 59b5e30f 757632d8
......@@ -5,6 +5,19 @@ node-liftoff (2.5.0-1) UNRELEASED; urgency=medium
-- Paolo Greppi <paolo.greppi@libpf.com> Thu, 05 Apr 2018 15:53:34 +0200
node-liftoff (2.3.0-3) unstable; urgency=medium
* Team upload
* Switch tests to pkg-js-tools and increase timeout (Closes: #853035)
* Bump debhelper compatibility level to 11
* Declare compliance with policy 4.3.0
* Change section to javascript
* Fix VCS fields
* Fix d/copyright
* Add upstream/metadata
-- Xavier Guimard <yadd@debian.org> Wed, 20 Feb 2019 20:39:06 +0100
node-liftoff (2.3.0-2) unstable; urgency=medium
* Team upload
......
Source: node-liftoff
Section: web
Priority: optional
Maintainer: Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Uploaders: Paolo Greppi <paolo.greppi@libpf.com>
Build-Depends:
debhelper (>= 9)
, dh-buildinfo
, node-findup-sync (>= 0.4.2)
, node-flagged-respawn (>= 0.3.2)
, node-resolve (>= 1.1.7)
, node-rechoir (>= 0.6.2)
, node-lodash-packages
, node-fined (>= 1.0.1)
, node-extend (>= 2.0)
, mocha
, chai
, node-sinon
, nodejs
Standards-Version: 4.1.1
Homepage: https://github.com/js-cli/js-liftoff
Vcs-Git: https://salsa.debian.org/js-team/node-liftoff.git
Section: javascript
Testsuite: autopkgtest-pkg-nodejs
Priority: optional
Build-Depends: debhelper (>= 11~),
dh-buildinfo,
node-findup-sync (>= 0.4.2),
node-flagged-respawn,
node-resolve (>= 1.1.7),
node-rechoir,
node-lodash-packages,
node-fined,
node-extend,
mocha,
chai,
node-sinon,
nodejs,
pkg-js-tools
Standards-Version: 4.3.0
Vcs-Browser: https://salsa.debian.org/js-team/node-liftoff
Vcs-Git: https://salsa.debian.org/js-team/node-liftoff.git
Homepage: https://github.com/js-cli/js-liftoff
Package: node-liftoff
Architecture: all
Depends:
${misc:Depends}
, nodejs
, node-extend (>= 2.0)
, node-findup-sync (>= 2.0.0)
, node-fined (>= 1.0.1)
, node-flagged-respawn (>= 1.0.0)
, node-is-plain-object (>= 2.0.4)
, node-object.map (>= 1.0.0)
, node-rechoir (>= 0.6.2)
, node-resolve (>= 1.1.7)
Depends: ${misc:Depends},
nodejs,
node-findup-sync (>= 0.4.2),
node-flagged-respawn,
node-resolve (>= 1.1.7),
node-rechoir,
node-lodash-packages,
node-fined,
node-extend
Description: command line tool launcher
Node.js module to make it easy for globally installed binaries
to find and load a local installation, no matter what version it is,
......
Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: liftoff
Upstream-Contact: https://github.com/js-cli/js-liftoff/issues
Source: https://github.com/js-cli/js-liftoff
Files: *
Copyright: 2016 Tyler Kellen (http://goingslowly.com/)
Copyright: 2014, Tyler Kellen (http://goingslowly.com/)
License: Expat
Files: debian/*
Copyright: 2016, Paolo Greppi <paolo.greppi@libpf.com>
2019, Xavier Guimard <yadd@debian.org>
License: GPL-3.0+
License: Expat
Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated documentation files
......@@ -28,10 +33,6 @@ License: Expat
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
Files: debian/*
Copyright: 2016 Paolo Greppi <paolo.greppi@libpf.com>
License: GPL-3.0+
License: GPL-3.0+
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
......@@ -44,7 +45,7 @@ License: GPL-3.0+
GNU General Public License for more details.
.
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
along with this program. If not, see <https://www.gnu.org/licenses/>.
.
On Debian systems, the complete text of the GNU General
Public License version 3 can be found in "/usr/share/common-licenses/GPL-3".
......@@ -5,12 +5,7 @@
#export DH_VERBOSE=1
%:
dh $@
#override_dh_auto_build:
override_dh_auto_test:
mocha -t 5000 -b -R spec test/index
dh $@ --with nodejs
override_dh_clean:
dh_clean
......
Tests: require
Depends: node-liftoff
Test-Command: mocha -t 5000 -b -R spec test/index
Depends: @, @builddeps@
mocha -t 20000 -b -R spec test/index
#!/bin/sh
set -e
nodejs -e "require('liftoff');"
---
Archive: GitHub
Bug-Database: https://github.com/js-cli/js-liftoff/issues
Contact: https://github.com/js-cli/js-liftoff/issues
Name: js-liftoff
Repository: https://github.com/js-cli/js-liftoff.git
Repository-Browse: https://github.com/js-cli/js-liftoff
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment