Commit 587ff7f7 authored by Xavier Guimard's avatar Xavier Guimard

Change debian/watch to use uscan grouped version

parent edc68c8a
node-mongodb (3.1.8+~3.0.2+~3.1.7+~1.0.1-2) UNRELEASED; urgency=medium
* Change debian/watch to use uscan grouped version
-- Xavier Guimard <yadd@debian.org> Tue, 30 Oct 2018 22:50:49 +0100
node-mongodb (3.1.8+~3.0.2+~3.1.7+~1.0.1-1) unstable; urgency=medium
* Add strict mode in debian/watch to avoid release-candidate in components
......
version=4
opts=dversionmangle=s/\+(debian|dfsg|ds|deb)(\.\d+)?$//,filenamemangle=s/.*=// \
https://qa.debian.org/cgi-bin/fakeupstream.cgi?upstream=npmjs/mongodb+npmjs/bson+npmjs/mongodb-core+npmjs/require_optional&strict=1 \
.*=mongodb_bson_mongodb-core_require_optional-(\d.*)@ARCHIVE_EXT@ debian
opts="searchmode=plain,pgpmode=none" \
https://registry.npmjs.org/mongodb https://registry.npmjs.org/mongodb/-/mongodb-(\d[\d\.]*)@ARCHIVE_EXT@ group
opts=dversionmangle=s/\+(debian|dfsg|ds|deb)(\.\d+)?$//,filenamemangle=s/.*=/bson/,component=bson \
https://qa.debian.org/cgi-bin/fakeupstream.cgi?upstream=npmjs/mongodb+npmjs/bson+npmjs/mongodb-core+npmjs/require_optional&component=bson&strict=1 \
.*=mongodb_bson_mongodb-core_require_optional-(\d.*)@ARCHIVE_EXT@ same
opts="searchmode=plain,pgpmode=none,component=bson" \
https://registry.npmjs.org/bson https://registry.npmjs.org/bson/-/bson-(\d[\d\.]*)@ARCHIVE_EXT@ group
opts=dversionmangle=s/\+(debian|dfsg|ds|deb)(\.\d+)?$//,filenamemangle=s/.*=/mongodb-core/,component=mongodb-core \
https://qa.debian.org/cgi-bin/fakeupstream.cgi?upstream=npmjs/mongodb+npmjs/bson+npmjs/mongodb-core+npmjs/require_optional&component=mongodb-core&strict=1 \
.*=mongodb_bson_mongodb-core_require_optional-(\d.*)@ARCHIVE_EXT@ same
opts="searchmode=plain,pgpmode=none,component=mongodb-core" \
https://registry.npmjs.org/mongodb-core https://registry.npmjs.org/mongodb-core/-/mongodb-core-(\d[\d\.]*)@ARCHIVE_EXT@ group
opts="searchmode=plain,pgpmode=none,component=requireoptional" \
https://registry.npmjs.org/require_optional https://registry.npmjs.org/require_optional/-/require_optional-(\d[\d\.]*)@ARCHIVE_EXT@ group
opts=dversionmangle=s/\+(debian|dfsg|ds|deb)(\.\d+)?$//,filenamemangle=s/.*=/requireoptional/,component=requireoptional \
https://qa.debian.org/cgi-bin/fakeupstream.cgi?upstream=npmjs/mongodb+npmjs/bson+npmjs/mongodb-core+npmjs/require_optional&component=require_optional&strict=1 \
.*=mongodb_bson_mongodb-core_require_optional-(\d.*)@ARCHIVE_EXT@ same
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment