Commit eec3bc6b authored by Xavier Guimard's avatar Xavier Guimard

Rename require_optional component to requireoptional

parent b51c09f1
[DEFAULT]
pristine-tar = True
sign-tags = True
component = [ 'bson', 'mongodb-core', 'require_optional' ]
component = [ 'bson', 'mongodb-core', 'requireoptional' ]
[import-orig]
filter = .gitignore
......@@ -4,8 +4,8 @@ bson/lib usr/lib/nodejs/bson/
mongodb-core/index.js usr/lib/nodejs/mongodb-core/
mongodb-core/package.json usr/lib/nodejs/mongodb-core/
mongodb-core/lib usr/lib/nodejs/mongodb-core/
require_optional/index.js usr/lib/nodejs/require_optional/
require_optional/package.json usr/lib/nodejs/require_optional/
requireoptional/index.js usr/lib/nodejs/require_optional/
requireoptional/package.json usr/lib/nodejs/require_optional/
index.js usr/lib/nodejs/mongodb/
package.json usr/lib/nodejs/mongodb/
lib usr/lib/nodejs/mongodb/
......@@ -17,7 +17,7 @@ override_dh_auto_build:
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
cd require_optional && mocha; cd -
cd requireoptional && mocha; cd -
cd bson && mocha ./test/node; cd -
endif
......
......@@ -5,7 +5,7 @@ TEMP=${ADTTMP:-${TMPDIR:-/tmp}}
TDIR=$(mktemp -d $TEMP/smokeXXXXXX)
PDIR=`pwd`
cp -a require_optional/test $TDIR
cp -a requireoptional/test $TDIR
cd $TDIR
ln -s /usr/lib/nodejs/require_optional/index.js .
mocha
......@@ -12,6 +12,6 @@ opts=dversionmangle=s/\+(debian|dfsg|ds|deb)(\.\d+)?$//,filenamemangle=s/.*=/mon
https://qa.debian.org/cgi-bin/fakeupstream.cgi?upstream=npmjs/mongodb+npmjs/bson+npmjs/mongodb-core+npmjs/require_optional&component=mongodb-core \
.*=mongodb_bson_mongodb-core_require_optional-(\d.*)@ARCHIVE_EXT@ same
opts=dversionmangle=s/\+(debian|dfsg|ds|deb)(\.\d+)?$//,filenamemangle=s/.*=/require-optional/,component=require_optional \
opts=dversionmangle=s/\+(debian|dfsg|ds|deb)(\.\d+)?$//,filenamemangle=s/.*=/requireoptional/,component=requireoptional \
https://qa.debian.org/cgi-bin/fakeupstream.cgi?upstream=npmjs/mongodb+npmjs/bson+npmjs/mongodb-core+npmjs/require_optional&component=require_optional \
.*=mongodb_bson_mongodb-core_require_optional-(\d.*)@ARCHIVE_EXT@ same
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment