New upstream version 2.0.1

parent a64c04ca
language: node_js
node_js:
- "0.8"
- "0.10"
\ No newline at end of file
- "0.10"
- "0.12"
before_install:
- '[ "${TRAVIS_NODE_VERSION}" != "0.8" ] || npm install -g npm@1.4.28'
- npm install -g npm
......@@ -2,9 +2,9 @@
Check and get file hashes (using any algorithm)
[![Build Status](https://travis-ci.org/ForbesLindesay/sha.png?branch=master)](https://travis-ci.org/ForbesLindesay/sha)
[![Dependency Status](https://gemnasium.com/ForbesLindesay/sha.png)](https://gemnasium.com/ForbesLindesay/sha)
[![NPM version](https://badge.fury.io/js/sha.png)](http://badge.fury.io/js/sha)
[![Build Status](https://img.shields.io/travis/ForbesLindesay/sha/master.svg)](https://travis-ci.org/ForbesLindesay/sha)
[![Dependency Status](https://img.shields.io/gemnasium/ForbesLindesay/sha.svg)](https://gemnasium.com/ForbesLindesay/sha)
[![NPM version](https://img.shields.io/npm/v/sha.svg)](http://badge.fury.io/js/sha)
## Installation
......
......@@ -2,20 +2,7 @@
var Transform = require('stream').Transform || require('readable-stream').Transform
var crypto = require('crypto')
var fs
try {
fs = require('graceful-fs')
} catch (ex) {
fs = require('fs')
}
try {
process.binding('crypto')
} catch (e) {
var er = new Error( 'crypto binding not found.\n'
+ 'Please build node with openssl.\n'
+ e.message )
throw er
}
var fs = require('graceful-fs')
exports.check = check
exports.checkSync = checkSync
......
{
"name": "sha",
"version": "1.2.3",
"version": "2.0.1",
"description": "Check and get file hashes",
"scripts": {
"test": "mocha -R spec"
......@@ -9,10 +9,10 @@
"type": "git",
"url": "https://github.com/ForbesLindesay/sha.git"
},
"license": "BSD",
"optionalDependencies": {
"graceful-fs": "2",
"readable-stream": "1.0"
"license": "(BSD-2-Clause OR MIT)",
"dependencies": {
"graceful-fs": "^4.1.2",
"readable-stream": "^2.0.2"
},
"devDependencies": {
"mocha": "~1.9.0"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment