Commit 9d9c2280 authored by Jérémy Lal's avatar Jérémy Lal

Build using shared http-parser

parent 91c99e86
......@@ -20,7 +20,7 @@ CDBS_BUILD_DEPENDS_rules_debhelper_v9 = debhelper (>=9.20160114)
# Needed by upstream build
# * recent gyp needed to build using flock
bdeps = binutils, openssl (>= $(ssl-minver)), pkg-config
bdeps +=, bash-completion, curl, procps, zlib1g-dev, libicu-dev, libc-ares-dev (>= 1.11.0), libnghttp2-dev
bdeps +=, bash-completion, curl, procps, zlib1g-dev, libicu-dev, libc-ares-dev (>= 1.11.0), libnghttp2-dev, libhttp-parser-dev
bdeps +=, libkvm-dev [kfreebsd-any], gyp (>= 0.1~svn1773)
# Needed for tests
bdeps +=, ca-certificates
......@@ -38,7 +38,7 @@ CDBS_PROVIDES_nodejs = nodejs-abi-$(abi)
DEB_COPYRIGHT_CHECK_IGNORE_REGEX = ^(deps/v8/benchmarks/v8-logo\.png|test/fixtures/person\.jpg.*|test/fixtures/sample\.png|test/fixtures/google_ssl_hello\.bin|test/fixtures/test_cert\.pfx|src/res/node\.ico|debian/(changelog|copyright(|_hints|_newhints)))$
DEB_CONFIGURE_NORMAL_ARGS =
DEB_CONFIGURE_EXTRA_FLAGS = --without-npm --shared-openssl --shared-zlib --shared-libuv --shared-cares --shared-nghttp2 --with-intl=system-icu --prefix=/usr --openssl-use-def-ca-store
DEB_CONFIGURE_EXTRA_FLAGS = --without-npm --shared-openssl --shared-zlib --shared-libuv --shared-cares --shared-nghttp2 --shared-http-parser --with-intl=system-icu --prefix=/usr --openssl-use-def-ca-store
# map HOST ARCH AND OS, and if unknown let upstream guess
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment