Commit 2b8b4a70 authored by Bryan Jen's avatar Bryan Jen

Merge pull request #79 from HAIL9000/maint/master/update_changelog_0.4.0

(maint) update changelog and module metadata
parents 94e4efa6 2526bc1b
##2016-03-30 - Release 0.4.0
###Summary
This release adds JSON output support for strings, fixes a major bug that prevented strings from working with the 4.4.0 release of puppet, and is the last version of strings that will be released as a module.
All related tickets can be found under the [PDOC][PDOC JIRA] JIRA project with the fix version of [0.4.0](https://tickets.puppetlabs.com/issues/?filter=18810).
###Features
- Support for JSON output **(PDOC-23)**
- Strings now has the ability to produce a JSON representation of a given puppet module
- The details of the JSON schema can be found [here](https://github.com/puppetlabs/puppetlabs-strings/blob/master/json_dom.md)
- For details on how to generate JSON, see the [README](https://github.com/puppetlabs/puppetlabs-strings/blob/master/README.md#running-puppet-strings)
- Migrate to ruby gems as a distribution method **(PDOC-28)**
- This is the last release of strings that will be available as a puppet module
- The 0.4.0 release will be released concurrently as a ruby gem
- After this release, all updates will only be available via the gem
###Bugfixes
- Fix issue that prevented strings from running with Puppet 4.4.0 **(PDOC-75)**
##2015-09-22 - Release 0.3.1
##Summary
###Summary
This is a minor bug fix release.
This is a minor bug fix release.
All related tickets can be found under the [PDOC][PDOC JIRA] JIRA project with the fix version of [0.3.1](https://tickets.puppetlabs.com/issues/?filter=15530).
......@@ -14,7 +36,7 @@ All related tickets can be found under the [PDOC][PDOC JIRA] JIRA project with t
##2015-09-21 - Release 0.3.0
##Summary
###Summary
This release includes support for Puppet Types and Providers, as well as
type checking Puppet 4x functions and defined types.
......@@ -45,6 +67,7 @@ the fix version of [0.3.0](https://tickets.puppetlabs.com/issues/?filter=15529).
##2015-03-17 - Release 0.2.0
###Summary
This release includes improvements to the HTML output generated by strings and a few bug fixes.
......
......@@ -24,7 +24,7 @@
"requirements": [
{
"name": "puppet",
"version_requirement": ">= 3.7.0"
"version_requirement": ">= 3.7.0 < 5.0.0"
}
]
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment