Commit 2dfc8073 authored by David Schmitt's avatar David Schmitt

(PDOC-259) relax ruby requirement to 2.1.0 from 2.1.9

This is required to support some edge-case scenarios with
older puppet versions.
parent d122b196
......@@ -22,5 +22,7 @@ matrix:
env: PUPPET_GEM_VERSION="~> 5" CHECK=spec
- rvm: 2.1.9
env: PUPPET_GEM_VERSION="~> 4" CHECK=rubocop
- rvm: 2.1.0
env: PUPPET_GEM_VERSION="~> 4" CHECK=spec
script: 'SPEC_OPTS="--format documentation" COVERAGE="yes" bundle exec rake $CHECK'
......@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.email = 'info@puppet.com'
s.homepage = 'https://github.com/puppetlabs/puppet-strings'
s.description = s.summary
s.required_ruby_version = '>= 2.1.9'
s.required_ruby_version = '>= 2.1.0'
s.extra_rdoc_files = [
'CHANGELOG.md',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment