Commit 6b5c2dbd authored by David Schmitt's avatar David Schmitt

Update Gemfile and gemspec

This adjusts the Gemfile and gemspec to current packaging
standards.
parent 3a1dcd75
......@@ -31,13 +31,7 @@ end
group :development do
gem 'github_changelog_generator', git: 'https://github.com/skywinder/github-changelog-generator', ref: '20ee04ba1234e9e83eb2ffb5056e23d641c7a018' if Gem::Version.new(RUBY_VERSION.dup) >= Gem::Version.new('2.2.2')
gem 'pry'
if RUBY_VERSION[0..2] == '1.9'
gem 'pry-debugger'
elsif RUBY_VERSION[0] == '2'
gem 'pry-byebug'
end
gem 'pry-byebug'
end
gem 'json', '<= 1.8' if RUBY_VERSION < '2.0.0'
gem 'json_pure', '<= 2.0.1' if RUBY_VERSION < '2.0.0'
gem 'rubocop', '<= 0.47.0' if RUBY_VERSION >= '2.0.0'
gem 'rubocop', '<= 0.47.0'
module PuppetStrings
VERSION = '2.0.0'.freeze
end
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'puppet-strings/version'
Gem::Specification.new do |s|
s.name = 'puppet-strings'
s.author = 'Puppet Inc.'
s.version = '2.0.0'
s.version = PuppetStrings::VERSION
s.license = 'Apache-2.0'
s.summary = 'Puppet documentation via YARD'
s.email = 'info@puppet.com'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment