Commit 8941fd9b authored by Harlan Lieberman-Berg's avatar Harlan Lieberman-Berg

New upstream version 0.31.0

parent ffb1e077
Metadata-Version: 2.1
Name: certbot-dns-ovh
Version: 0.28.0
Version: 0.31.0
Summary: OVH DNS Authenticator plugin for Certbot
Home-page: https://github.com/certbot/certbot
Author: Certbot Project
......
Metadata-Version: 2.1
Name: certbot-dns-ovh
Version: 0.28.0
Version: 0.31.0
Summary: OVH DNS Authenticator plugin for Certbot
Home-page: https://github.com/certbot/certbot
Author: Certbot Project
......
acme>=0.21.1
certbot>=0.21.1
acme>=0.31.0
certbot>=0.31.0
dns-lexicon>=2.7.14
mock
setuptools
......
......@@ -77,15 +77,17 @@ class _OVHLexiconClient(dns_common_lexicon.LexiconClient):
def __init__(self, endpoint, application_key, application_secret, consumer_key, ttl):
super(_OVHLexiconClient, self).__init__()
self.provider = ovh.Provider({
'provider_name': 'ovh',
config = dns_common_lexicon.build_lexicon_config('ovh', {
'ttl': ttl,
}, {
'auth_entrypoint': endpoint,
'auth_application_key': application_key,
'auth_application_secret': application_secret,
'auth_consumer_key': consumer_key,
'ttl': ttl,
})
self.provider = ovh.Provider(config)
def _handle_http_error(self, e, domain_name):
hint = None
if str(e).startswith('400 Client Error:'):
......
import sys
from setuptools import setup
from setuptools import find_packages
version = '0.28.0'
version = '0.31.0'
# Remember to update local-oldest-requirements.txt when changing the minimum
# acme/certbot version.
install_requires = [
'acme>=0.21.1',
'certbot>=0.21.1',
'dns-lexicon>=2.7.14', # Correct proxy use on OVH provider
'acme>=0.31.0',
'certbot>=0.31.0',
'dns-lexicon>=2.7.14', # Correct proxy use on OVH provider
'mock',
'setuptools',
'zope.interface',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment