Skip to content
Snippets Groups Projects
Commit 4565a655 authored by Guido Günther's avatar Guido Günther
Browse files

drop superflous headers and footers from remaining patches

parent cecac4c2
No related branches found
No related tags found
No related merge requests found
From dd53d550311316241c3999ff5573ab88d9825319 Mon Sep 17 00:00:00 2001
From: Guido Guenther <agx@sigxcpu.org>
Date: Fri, 7 Mar 2008 09:08:25 +0100
Subject: [PATCH] remove-RHism.diff
......@@ -21,5 +20,3 @@ index 063dde7..751c6aa 100644
Most \fBvirsh\fR commands require root privileges to run due to the
communications channels used to talk to the hypervisor. Running as
--
1.5.6.5
From f7cfb3813be36f8178392e0d313935d4fd97e49a Mon Sep 17 00:00:00 2001
From: Guido Guenther <agx@sigxcpu.org>
Date: Fri, 7 Mar 2008 09:08:26 +0100
Subject: [PATCH] qemu-disable-network.diff
......@@ -9,10 +8,10 @@ Subject: [PATCH] qemu-disable-network.diff
2 files changed, 0 insertions(+), 6 deletions(-)
diff --git a/qemud/Makefile.am b/qemud/Makefile.am
index 5d6ff63..29ff58c 100644
index 15d3717..d6b4ceb 100644
--- a/qemud/Makefile.am
+++ b/qemud/Makefile.am
@@ -107,9 +107,6 @@ install-data-local: install-init install-data-sasl install-data-polkit
@@ -138,9 +138,6 @@ install-data-local: install-init install-data-sasl install-data-polkit
$(DESTDIR)$(sysconfdir)/$(default_xml_dest)
sed -i -e "s,</name>,</name>\n <uuid>$(UUID)</uuid>," \
$(DESTDIR)$(sysconfdir)/$(default_xml_dest)
......@@ -23,10 +22,10 @@ index 5d6ff63..29ff58c 100644
mkdir -p $(DESTDIR)$(localstatedir)/run/libvirt
mkdir -p $(DESTDIR)$(localstatedir)/lib/libvirt
diff --git a/qemud/Makefile.in b/qemud/Makefile.in
index 6b7cefe..7293b86 100644
index 7735a0a..561163c 100644
--- a/qemud/Makefile.in
+++ b/qemud/Makefile.in
@@ -1092,9 +1092,6 @@ remote_protocol.c: remote_protocol.h
@@ -1195,9 +1195,6 @@ remote_protocol.c: remote_protocol.h
@WITH_LIBVIRTD_TRUE@ $(DESTDIR)$(sysconfdir)/$(default_xml_dest)
@WITH_LIBVIRTD_TRUE@ sed -i -e "s,</name>,</name>\n <uuid>$(UUID)</uuid>," \
@WITH_LIBVIRTD_TRUE@ $(DESTDIR)$(sysconfdir)/$(default_xml_dest)
......@@ -37,5 +36,3 @@ index 6b7cefe..7293b86 100644
@WITH_LIBVIRTD_TRUE@ mkdir -p $(DESTDIR)$(localstatedir)/run/libvirt
@WITH_LIBVIRTD_TRUE@ mkdir -p $(DESTDIR)$(localstatedir)/lib/libvirt
--
1.5.6.5
From 1dcda30d8561d13c6f6aa18c98a0403990033d35 Mon Sep 17 00:00:00 2001
From: Guido Guenther <agx@sigxcpu.org>
Date: Thu, 26 Jun 2008 20:01:38 +0200
Subject: [PATCH] allow libvirt group to access the socket
......@@ -8,10 +7,10 @@ Subject: [PATCH] allow libvirt group to access the socket
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/qemud/libvirtd.conf b/qemud/libvirtd.conf
index c323185..cff232d 100644
index a12a897..804fe07 100644
--- a/qemud/libvirtd.conf
+++ b/qemud/libvirtd.conf
@@ -75,7 +75,7 @@
@@ -78,7 +78,7 @@
# without becoming root.
#
# This is restricted to 'root' by default.
......@@ -20,7 +19,7 @@ index c323185..cff232d 100644
# Set the UNIX socket permissions for the R/O socket. This is used
# for monitoring VM status only
@@ -92,7 +92,7 @@
@@ -95,7 +95,7 @@
#
# If not using PolicyKit and setting group ownership for access
# control then you may want to relax this to:
......@@ -29,7 +28,7 @@ index c323185..cff232d 100644
@@ -122,7 +122,7 @@
@@ -125,7 +125,7 @@
#
# To restrict monitoring of domains you may wish to enable
# an authentication mechanism here
......@@ -38,7 +37,7 @@ index c323185..cff232d 100644
# Set an authentication scheme for UNIX read-write sockets
# By default socket permissions only allow root. If PolicyKit
@@ -131,7 +131,7 @@
@@ -134,7 +134,7 @@
#
# If the unix_sock_rw_perms are changed you may wish to enable
# an authentication mechanism here
......@@ -48,5 +47,3 @@ index c323185..cff232d 100644
# Change the authentication scheme for TCP sockets.
#
--
1.5.6.5
From 980884e56d54487dd57383d8802b1f5fe2b9b571 Mon Sep 17 00:00:00 2001
From: Harald Staub <harald.staub@switch.ch>
Date: Tue, 2 Dec 2008 13:14:33 +0100
Subject: [PATCH] Open qemu monitor log O_APPEND instead of O_TRUNC
......@@ -23,5 +22,3 @@ index e666efc..a5fade4 100644
qemudReportError(conn, NULL, NULL, VIR_ERR_INTERNAL_ERROR,
_("failed to create logfile %s: %s"),
--
1.6.0.3
From 42e1e104ca11ce85c8ca8094ac11a26ceb94f070 Mon Sep 17 00:00:00 2001
From: =?utf-8?q?Guido=20G=C3=BCnther?= <agx@sigxcpu.org>
Date: Thu, 11 Dec 2008 12:02:50 +0100
Subject: [PATCH] qemu: fix parallel/serial mode "tcp" and "unix"
......@@ -59,5 +58,3 @@ index f2d1f17..ad37de4 100644
-LC_ALL=C PATH=/bin HOME=/home/test USER=test LOGNAME=test /usr/bin/qemu -S -M pc -m 214 -smp 1 -nographic -monitor pty -no-acpi -boot c -hda /dev/HostVG/QEMUGuest1 -net none -serial telnet:127.0.0.1:9999,server -parallel none -usb
+LC_ALL=C PATH=/bin HOME=/home/test USER=test LOGNAME=test /usr/bin/qemu -S -M pc -m 214 -smp 1 -nographic -monitor pty -no-acpi -boot c -hda /dev/HostVG/QEMUGuest1 -net none -serial telnet:127.0.0.1:9999,server,nowait -parallel none -usb
--
1.6.0.3
From 91970e9687f16337a5a72cb7a4eeb25e982be02e Mon Sep 17 00:00:00 2001
From: Daniel P. Berrange <berrange@redhat.com>
Date: Wed, 17 Dec 2008 16:55:58 +0000
Subject: [PATCH] Fix missing read-only access checks (CVE-2008-5086)
......@@ -208,5 +207,3 @@ index a279024..1b0e31a 100644
if (conn->storageDriver && conn->storageDriver->poolSetAutostart)
--
1.6.0.3
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment