Skip to content
Snippets Groups Projects
Commit 761db176 authored by Guido Günther's avatar Guido Günther
Browse files

Rediff patches

Dropped virNetSocketCheckProtocols-handle-EAI_NONAME-as-IPv6.patch: applied upstram
parent 6fe9265c
No related branches found
No related tags found
No related merge requests found
......@@ -8,10 +8,10 @@ Subject: Debianize systemd service files
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/daemon/libvirtd.service.in b/daemon/libvirtd.service.in
index 1759ac8..5269a7f 100644
index 9e67e43..d9b0841 100644
--- a/daemon/libvirtd.service.in
+++ b/daemon/libvirtd.service.in
@@ -10,8 +10,8 @@ Documentation=http://libvirt.org
@@ -12,8 +12,8 @@ Documentation=http://libvirt.org
[Service]
Type=notify
......
......@@ -9,10 +9,10 @@ to not interfere with existing network configurations
2 files changed, 6 deletions(-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 7338ab9..450a010 100644
index 57a06e8..d34351f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2811,9 +2811,6 @@ if WITH_NETWORK
@@ -2833,9 +2833,6 @@ if WITH_NETWORK
cp $(DESTDIR)$(confdir)/qemu/networks/default.xml.t \
$(DESTDIR)$(confdir)/qemu/networks/default.xml && \
rm $(DESTDIR)$(confdir)/qemu/networks/default.xml.t; }
......@@ -23,10 +23,10 @@ index 7338ab9..450a010 100644
uninstall-local:: uninstall-init uninstall-systemd
diff --git a/src/Makefile.in b/src/Makefile.in
index 7533c55..51c10bc 100644
index 8159cca..7a2d2ee 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -10565,9 +10565,6 @@ install-data-local: install-init install-systemd
@@ -10581,9 +10581,6 @@ install-data-local: install-init install-systemd
@WITH_NETWORK_TRUE@ cp $(DESTDIR)$(confdir)/qemu/networks/default.xml.t \
@WITH_NETWORK_TRUE@ $(DESTDIR)$(confdir)/qemu/networks/default.xml && \
@WITH_NETWORK_TRUE@ rm $(DESTDIR)$(confdir)/qemu/networks/default.xml.t; }
......
......@@ -8,7 +8,7 @@ As of 1.2.16 upstream ships a Polkit rule like Debian does.
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 59bc4d4..844e532 100644
index be1b5a9..ddd3ddc 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -301,14 +301,14 @@ install-data-polkit::
......
......@@ -7,7 +7,7 @@ Subject: remove-RHism.diff
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/virsh.pod b/tools/virsh.pod
index 5ee9a96..c008cc8 100644
index 83c445d3..fceab91 100644
--- a/tools/virsh.pod
+++ b/tools/virsh.pod
@@ -119,7 +119,7 @@ virsh is coming from and which options and driver are compiled in.
......
......@@ -42,7 +42,7 @@ to savely detect that the command 'info migrate' is not implemented.
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/qemu/qemu_monitor_text.c b/src/qemu/qemu_monitor_text.c
index 2aa0460..0c8fbff 100644
index d5ef089..7e39a9d 100644
--- a/src/qemu/qemu_monitor_text.c
+++ b/src/qemu/qemu_monitor_text.c
@@ -1471,7 +1471,15 @@ int qemuMonitorTextGetMigrationStatus(qemuMonitorPtr mon,
......
......@@ -13,4 +13,3 @@ debian/Use-upstreams-polkit-rule.patch
Allow-access-to-libnl-3-config-files.patch
debian/apparmor_profiles_local_include.patch
debian/libsystemd.patch
virNetSocketCheckProtocols-handle-EAI_NONAME-as-IPv6.patch
From: =?utf-8?q?Guido_G=C3=BCnther?= <agx@sigxcpu.org>
Date: Tue, 11 Aug 2015 11:49:18 +0200
Subject: virNetSocketCheckProtocols: handle EAI_NONAME as IPv6 unavailable
When running the testsuite using "unshare -n" we might have IPv6 but no
configure addresses. Due to AI_ADDRCONFIG getaddrinfo then fails with
EAI_NONAME which we should then treat as IPv6 unavailable.
---
src/rpc/virnetsocket.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/rpc/virnetsocket.c b/src/rpc/virnetsocket.c
index 106d09a..5e5f1ab 100644
--- a/src/rpc/virnetsocket.c
+++ b/src/rpc/virnetsocket.c
@@ -183,7 +183,8 @@ int virNetSocketCheckProtocols(bool *hasIPv4,
if ((gaierr = getaddrinfo("::1", NULL, &hints, &ai)) != 0) {
if (gaierr == EAI_ADDRFAMILY ||
- gaierr == EAI_FAMILY) {
+ gaierr == EAI_FAMILY ||
+ gaierr == EAI_NONAME) {
*hasIPv6 = false;
} else {
virReportError(VIR_ERR_INTERNAL_ERROR,
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment