Skip to content
Snippets Groups Projects
Commit 7d4f947d authored by Guido Günther's avatar Guido Günther
Browse files

Rediff patches

parent a40d4d38
No related branches found
No related tags found
No related merge requests found
......@@ -39,12 +39,12 @@ index 5f3ec70..3b5fade 100644
</define>
diff --git a/src/xen/xen_hypervisor.c b/src/xen/xen_hypervisor.c
index a081eaf..b2739ff 100644
index 6626bb5..069dc43 100644
--- a/src/xen/xen_hypervisor.c
+++ b/src/xen/xen_hypervisor.c
@@ -2144,11 +2144,9 @@ xenHypervisorBuildCapabilities(virConnectPtr conn, virArch hostarch,
if ((guest = virCapabilitiesAddGuest(caps,
guest_archs[i].hvm ? "hvm" : "xen",
guest_archs[i].hvm ? VIR_DOMAIN_OSTYPE_HVM : VIR_DOMAIN_OSTYPE_XEN,
guest_archs[i].arch,
- (hostarch == VIR_ARCH_X86_64 ?
- "/usr/lib64/xen/bin/qemu-dm" :
......
......@@ -10,10 +10,10 @@ Closes: #663931
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/util/virutil.c b/src/util/virutil.c
index 658723b..1da905a 100644
index 0426517..5aa30ee 100644
--- a/src/util/virutil.c
+++ b/src/util/virutil.c
@@ -1490,7 +1490,7 @@ virSetUIDGIDWithCaps(uid_t uid, gid_t gid, gid_t *groups, int ngroups,
@@ -1486,7 +1486,7 @@ virSetUIDGIDWithCaps(uid_t uid, gid_t gid, gid_t *groups, int ngroups,
void virFileWaitForDevices(void)
{
# ifdef UDEVADM
......
......@@ -9,7 +9,7 @@ without sysfs mounted.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/vircgrouptest.c b/tests/vircgrouptest.c
index bbf28d1..94adeb9 100644
index dddf33a..f7f5278 100644
--- a/tests/vircgrouptest.c
+++ b/tests/vircgrouptest.c
@@ -22,7 +22,7 @@
......
......@@ -9,10 +9,10 @@ to not interfere with existing network configurations
2 files changed, 6 deletions(-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 91a4c17..28fdbad 100644
index 17cf318..3a3b5a2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2719,9 +2719,6 @@ if WITH_NETWORK
@@ -2739,9 +2739,6 @@ if WITH_NETWORK
cp $(DESTDIR)$(confdir)/qemu/networks/default.xml.t \
$(DESTDIR)$(confdir)/qemu/networks/default.xml && \
rm $(DESTDIR)$(confdir)/qemu/networks/default.xml.t; }
......@@ -23,10 +23,10 @@ index 91a4c17..28fdbad 100644
uninstall-local:: uninstall-init uninstall-systemd
diff --git a/src/Makefile.in b/src/Makefile.in
index 6a5ba65..9cb88fb 100644
index 5938f6e..9683055 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -10424,9 +10424,6 @@ install-data-local: install-init install-systemd
@@ -10439,9 +10439,6 @@ install-data-local: install-init install-systemd
@WITH_NETWORK_TRUE@ cp $(DESTDIR)$(confdir)/qemu/networks/default.xml.t \
@WITH_NETWORK_TRUE@ $(DESTDIR)$(confdir)/qemu/networks/default.xml && \
@WITH_NETWORK_TRUE@ rm $(DESTDIR)$(confdir)/qemu/networks/default.xml.t; }
......
......@@ -12,7 +12,7 @@ Closes: #517059
5 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/xen/xen_hypervisor.c b/src/xen/xen_hypervisor.c
index bc498ff..a081eaf 100644
index 431c47a..6626bb5 100644
--- a/src/xen/xen_hypervisor.c
+++ b/src/xen/xen_hypervisor.c
@@ -2148,7 +2148,7 @@ xenHypervisorBuildCapabilities(virConnectPtr conn, virArch hostarch,
......
......@@ -7,7 +7,7 @@ Subject: remove-RHism.diff
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/virsh.pod b/tools/virsh.pod
index 63325ff..3dc8f63 100644
index f8496f3..5fa6da2 100644
--- a/tools/virsh.pod
+++ b/tools/virsh.pod
@@ -119,7 +119,7 @@ virsh is coming from and which options and driver are compiled in.
......
......@@ -42,10 +42,10 @@ to savely detect that the command 'info migrate' is not implemented.
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/qemu/qemu_monitor_text.c b/src/qemu/qemu_monitor_text.c
index 9973a17..809196d 100644
index f26bc78..9e24a6c 100644
--- a/src/qemu/qemu_monitor_text.c
+++ b/src/qemu/qemu_monitor_text.c
@@ -1479,7 +1479,15 @@ int qemuMonitorTextGetMigrationStatus(qemuMonitorPtr mon,
@@ -1476,7 +1476,15 @@ int qemuMonitorTextGetMigrationStatus(qemuMonitorPtr mon,
}
status->disk_total *= 1024;
}
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment