Skip to content
Snippets Groups Projects
Commit c0ad5618 authored by Guido Günther's avatar Guido Günther
Browse files

Rediff patches

Dropped Use-daemon-log-facility-for-journald.patch: <REASON>
parent 8109247d
No related branches found
No related tags found
No related merge requests found
From: =?utf-8?q?Guido_G=C3=BCnther?= <agx@sigxcpu.org>
Date: Mon, 21 Sep 2015 20:06:55 +0200
Subject: Use daemon log facility for journald
otherwise messages end up in /var/log/kern.log if journald forwards to
syslog.
Closes: #799633
---
src/util/virlog.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/util/virlog.c b/src/util/virlog.c
index b45ee91..627f4cb 100644
--- a/src/util/virlog.c
+++ b/src/util/virlog.c
@@ -920,6 +920,7 @@ virLogOutputToJournald(virLogSourcePtr source,
journalAddString(&state, "MESSAGE", rawstr);
journalAddInt(&state, "PRIORITY",
virLogPrioritySyslog(priority));
+ journalAddInt(&state, "SYSLOG_FACILITY", LOG_DAEMON);
journalAddString(&state, "LIBVIRT_SOURCE", source->name);
if (filename)
journalAddString(&state, "CODE_FILE", filename);
......@@ -9,10 +9,10 @@ to not interfere with existing network configurations
2 files changed, 6 deletions(-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 4291375..d5440c4 100644
index 07d5879..5156d9b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2840,9 +2840,6 @@ if WITH_NETWORK
@@ -2841,9 +2841,6 @@ if WITH_NETWORK
cp $(DESTDIR)$(confdir)/qemu/networks/default.xml.t \
$(DESTDIR)$(confdir)/qemu/networks/default.xml && \
rm $(DESTDIR)$(confdir)/qemu/networks/default.xml.t; }
......@@ -23,7 +23,7 @@ index 4291375..d5440c4 100644
uninstall-local:: uninstall-init uninstall-systemd
diff --git a/src/Makefile.in b/src/Makefile.in
index 3e164c9..de72e91 100644
index 4cf6dd1..5e0937d 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -10588,9 +10588,6 @@ install-data-local: install-init install-systemd
......
......@@ -7,7 +7,7 @@ Subject: remove-RHism.diff
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/virsh.pod b/tools/virsh.pod
index 83c445d3..fceab91 100644
index 0212e7a..3739f9d 100644
--- a/tools/virsh.pod
+++ b/tools/virsh.pod
@@ -119,7 +119,7 @@ virsh is coming from and which options and driver are compiled in.
......
......@@ -42,7 +42,7 @@ to savely detect that the command 'info migrate' is not implemented.
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/qemu/qemu_monitor_text.c b/src/qemu/qemu_monitor_text.c
index d5ef089..7e39a9d 100644
index f44da20..039e023 100644
--- a/src/qemu/qemu_monitor_text.c
+++ b/src/qemu/qemu_monitor_text.c
@@ -1471,7 +1471,15 @@ int qemuMonitorTextGetMigrationStatus(qemuMonitorPtr mon,
......
......@@ -13,4 +13,3 @@ debian/Use-upstreams-polkit-rule.patch
Allow-access-to-libnl-3-config-files.patch
debian/apparmor_profiles_local_include.patch
debian/libsystemd.patch
Use-daemon-log-facility-for-journald.patch
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment