Skip to content
Snippets Groups Projects
Commit f94fb482 authored by Guido Günther's avatar Guido Günther
Browse files

drop 0005-allow-to-qemu-to-emulate-arm.patch

fixed upstream.
parent e764583a
No related branches found
No related tags found
No related merge requests found
......@@ -22,10 +22,10 @@ index 403846a..c3f41d4 100644
mkdir -p $(DESTDIR)$(localstatedir)/run/libvirt
mkdir -p $(DESTDIR)$(localstatedir)/lib/libvirt
diff --git a/qemud/Makefile.in b/qemud/Makefile.in
index dbc6bb3..e8dfa5b 100644
index ed8cea0..bb1e1bd 100644
--- a/qemud/Makefile.in
+++ b/qemud/Makefile.in
@@ -1307,9 +1307,6 @@ remote_protocol.c: remote_protocol.h
@@ -1375,9 +1375,6 @@ remote_protocol.c: remote_protocol.h
@WITH_LIBVIRTD_TRUE@ test -z "$(UUID)" || \
@WITH_LIBVIRTD_TRUE@ sed -i -e "s,</name>,</name>\n <uuid>$(UUID)</uuid>," \
@WITH_LIBVIRTD_TRUE@ $(DESTDIR)$(sysconfdir)/$(default_xml_dest)
......
......@@ -7,7 +7,7 @@ Subject: [PATCH] allow libvirt group to access the socket
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/qemud/libvirtd.conf b/qemud/libvirtd.conf
index 1fd5918..a26c081 100644
index 49de466..cc5f056 100644
--- a/qemud/libvirtd.conf
+++ b/qemud/libvirtd.conf
@@ -78,7 +78,7 @@
......
......@@ -8,10 +8,10 @@ Closes: #517059
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/xen_internal.c b/src/xen_internal.c
index 06b0cba..252772d 100644
index cc5a8f9..63b8785 100644
--- a/src/xen_internal.c
+++ b/src/xen_internal.c
@@ -2202,7 +2202,7 @@ xenHypervisorBuildCapabilities(virConnectPtr conn,
@@ -2212,7 +2212,7 @@ xenHypervisorBuildCapabilities(virConnectPtr conn,
"/usr/lib64/xen/bin/qemu-dm" :
"/usr/lib/xen/bin/qemu-dm"),
(guest_archs[i].hvm ?
......
From: C.J. Adams-Collier <cjac@colliertech.org>
Date: Fri, 3 Jul 2009 19:12:55 +0200
Subject: [PATCH] allow to qemu to emulate arm
---
src/qemu_conf.c | 8 ++++++++
1 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/src/qemu_conf.c b/src/qemu_conf.c
index d54f2ca..15f9795 100644
--- a/src/qemu_conf.c
+++ b/src/qemu_conf.c
@@ -186,6 +186,12 @@ int qemudLoadDriverConfig(struct qemud_driver *driver,
static const char *const arch_info_hvm_x86_machines[] = {
"pc", "isapc"
};
+static const char *const arch_info_hvm_arm_machines[] = {
+ "versatilepb","integratorcp","versatileab","realview",
+ "akita","spitz","borzoi","terrier","sx1-v1","sx1",
+ "cheetah","n800","n810","lm3s811evb","lm3s6965evb",
+ "connex","verdex","mainstone","musicpal","tosa",
+};
static const char *const arch_info_hvm_mips_machines[] = {
"mips"
};
@@ -236,6 +242,8 @@ static const struct qemu_arch_info const arch_info_hvm[] = {
"/usr/bin/qemu", "/usr/bin/qemu-system-x86_64", arch_info_i686_flags, 4 },
{ "x86_64", 64, arch_info_hvm_x86_machines, 2,
"/usr/bin/qemu-system-x86_64", NULL, arch_info_x86_64_flags, 2 },
+ { "arm", 32, arch_info_hvm_arm_machines, 20,
+ "/usr/bin/qemu-system-arm", NULL, NULL, 0 },
{ "mips", 32, arch_info_hvm_mips_machines, 1,
"/usr/bin/qemu-system-mips", NULL, NULL, 0 },
{ "mipsel", 32, arch_info_hvm_mips_machines, 1,
--
......@@ -2,4 +2,3 @@
0002-qemu-disable-network.diff.patch
0003-allow-libvirt-group-to-access-the-socket.patch
0004-fix-Debian-specific-path-to-hvm-loader.patch
0005-allow-to-qemu-to-emulate-arm.patch
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment