Commit 1b3b6f9d authored by Guido Günther's avatar Guido Günther

Fix spice availability detection

gi.require_version('SpiceClientGtk', '3.0') raises ValueError if
SpiceClientGtk is not installed so we never see ImportError. Check for
both in case the module is there but the symbol went missing.

Closes: #799771
parent 67cdd3ee
virt-manager (1:1.3.2-2) unstable; urgency=medium
* Upload to unstable
* [8a27ee8] Fix spice availability detection
gi.require_version('SpiceClientGtk', '3.0') raises ValueError if
SpiceClientGtk is not installed so we never see ImportError. Check for
both in case the module is there but the symbol went missing.
Thanks: Adel Belhouane for the patch
(Closes: #799771)
-- Guido Günther <agx@sigxcpu.org> Tue, 29 Mar 2016 08:18:25 +0200
virt-manager (1:1.3.2-1) experimental; urgency=medium
* [74c0cce] Move python-ipaddr dependency from virt-manager to virtinst
......
......@@ -51,7 +51,7 @@ index b424e90..b9c7512 100644
+ from gi.repository import SpiceClientGtk
+ from gi.repository import SpiceClientGLib
+ have_spice_gtk = True
+except ImportError:
+except (ValueError, ImportError):
+ have_spice_gtk = False
import logging
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment