Commit 2abff22c authored by Felix Lechner's avatar Felix Lechner Committed by Chris Lamb

Add build-deps for PE32/PE32+ binary related tests.

Two new tests for the previously untested tag
'portable-executable-missing-security-features' require some
MinGW-related packages. Adds the required build-dependencies to
d/control.

The dependencies are marked <!nocheck>. They are available in
oo-stable.

Tests are disabled when their dependencies are unavailable. Missing
test dependencies will generally not affect package building on less
common architectures.

Gbp-Dch: ignore
parent 13030848
...@@ -25,6 +25,8 @@ Build-Depends: ...@@ -25,6 +25,8 @@ Build-Depends:
dpkg (>= 1.17.14), dpkg (>= 1.17.14),
fakeroot <!nocheck>, fakeroot <!nocheck>,
file <!nocheck>, file <!nocheck>,
gcc-mingw-w64-i686 <!nocheck>,
gcc-mingw-w64-x86-64 <!nocheck>,
gettext <!nocheck>, gettext <!nocheck>,
gpg <!nocheck>, gpg <!nocheck>,
gpg-agent <!nocheck>, gpg-agent <!nocheck>,
...@@ -67,6 +69,7 @@ Build-Depends: ...@@ -67,6 +69,7 @@ Build-Depends:
libxml-simple-perl <!nocheck>, libxml-simple-perl <!nocheck>,
libyaml-libyaml-perl <!nocheck>, libyaml-libyaml-perl <!nocheck>,
man-db <!nocheck>, man-db <!nocheck>,
mingw-w64-tools <!nocheck>,
node-uglify <!nocheck>, node-uglify <!nocheck>,
patchutils <!nocheck>, patchutils <!nocheck>,
perl <!nocheck>, perl <!nocheck>,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment