Commit 3890ede1 authored by Chris Lamb's avatar Chris Lamb 💬

Add a note that packages might have added the required dependency for...

Add a note that packages might have added the required dependency for missing-versioned-depends-on-init-system-helpers to Build-Depends instead of the binary package (eg. in src:lbcd).
parent 8ebf03f0
Pipeline #23284 failed with stage
in 0 seconds
......@@ -948,7 +948,9 @@ Certainty: possible
Ref: update.d(8), #910593
Info: This package uses a command in the specified maintainer script
but does not specify an appropriate minimum dependency on the
<tt>init-system-helpers</tt> package.
<tt>init-system-helpers</tt> package. It may have been added to the
package's <tt>Build-Depends</tt> instead of the corresponding binary
package.
.
For example, the <tt>defaults-disabled</tt> option was added to
<tt>update-rc.d</tt> in <tt>init-system-helpers</tt> version 1.50.
......
......@@ -11,6 +11,9 @@ lintian (2.5.111) UNRELEASED; urgency=medium
* checks/scripts.desc:
+ [CL] Warn about packages that use PIUPARTS_TEST (etc.) in their
maintainer scripts. Thanks to Holger Levsen. (Closes: #912040)
+ [CL] Add a note that packages might have added the required
dependency for missing-versioned-depends-on-init-system-helpers to
Build-Depends instead of the binary package (eg. in src:lbcd).
* data/spelling/corrections:
+ [CL] Add a "recognise" connection re. MR: !59.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment