Commit 6f21566e authored by Chris Lamb's avatar Chris Lamb 💬

Upgrade package-uses-vendor-specific-patch-series to "E:" severity following...

Upgrade package-uses-vendor-specific-patch-series to "E:" severity following the release of buster (see #904302).
parent ff47280b
...@@ -231,7 +231,7 @@ Info: Lintian found a spelling, grammar or capitalization error in the ...@@ -231,7 +231,7 @@ Info: Lintian found a spelling, grammar or capitalization error in the
similar) are ignored by Lintian. similar) are ignored by Lintian.
Tag: package-uses-vendor-specific-patch-series Tag: package-uses-vendor-specific-patch-series
Severity: normal Severity: important
Certainty: certain Certainty: certain
Info: The specified series file is a vendor-specific patch series file. Info: The specified series file is a vendor-specific patch series file.
. .
...@@ -240,9 +240,6 @@ Info: The specified series file is a vendor-specific patch series file. ...@@ -240,9 +240,6 @@ Info: The specified series file is a vendor-specific patch series file.
However, since Debian source packages are usually treated as a pure However, since Debian source packages are usually treated as a pure
transport format this can cause confusion and frustration. transport format this can cause confusion and frustration.
. .
After Buster is released, the presence of a vendor-specific patch
series will be a violation of a MUST directive in Debian policy.
.
Please migrate away from such series files and consider alternatives Please migrate away from such series files and consider alternatives
such differing source packages or modify the build process to behave such differing source packages or modify the build process to behave
conditionally or to conditionally patch files explicitly. conditionally or to conditionally patch files explicitly.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment