Commit ac22174d authored by Chris Lamb's avatar Chris Lamb 💬

checks/debhelper.desc: Update tag descriptions to use the new recommended compat level as examples.

parent 0aad30a7
......@@ -20,9 +20,9 @@ Certainty: possible
Info: If a package uses debhelper, it must declare a Build-Depends
on debhelper or on the debhelper-compat virtual package. For example:
.
Build-Depends: debhelper (>= 11~)
Build-Depends: debhelper (>= 12~)
.
Build-Depends: debhelper-compat (= 11)
Build-Depends: debhelper-compat (= 12)
Tag: package-lacks-versioned-build-depends-on-debhelper
Severity: pedantic
......@@ -59,7 +59,7 @@ Info: The package either doesn't declare a versioned build dependency on
alternatively Build-Depend on the debhelper-compat virtual package, for
example:
.
Build-Depends: debhelper-compat (= 11)
Build-Depends: debhelper-compat (= 12)
.
Note if you are using a compat level marked as experimental (such as
compat 12 in debhelper 11.4~) please explicitly override this tag.
......@@ -113,7 +113,7 @@ Info: The debhelper compatibility version used by this package is marked
using a newer compatibility version.
.
The compatibility version can be set by specifying
<tt>debhelper-compat (= 11)</tt> in your package's
<tt>debhelper-compat (= 12)</tt> in your package's
<tt>Build-Depends</tt>, by the legacy <tt>debian/compat</tt> file or
even by setting and exporting DH_COMPAT in <tt>debian/rules</tt>. If it
is not set in either place, debhelper defaults to the deprecated
......@@ -128,7 +128,7 @@ Info: The debhelper compatibility version used by this package is marked
using a recommended compatibility version.
.
The compatibility version can be set by specifying
<tt>debhelper-compat (= 11)</tt> in your package's
<tt>debhelper-compat (= 12)</tt> in your package's
<tt>Build-Depends</tt>, by the legacy <tt>debian/compat</tt> file or
even by setting and exporting DH_COMPAT in <tt>debian/rules</tt>. If it
is not set in either place, debhelper defaults to the deprecated
......@@ -143,7 +143,7 @@ Info: The debhelper compatibility version used by this package is marked
stable compatibility version instead.
.
The compatibility version can be set by specifying
<tt>debhelper-compat (= 11)</tt> in your package's
<tt>debhelper-compat (= 12)</tt> in your package's
<tt>Build-Depends</tt>, by the legacy <tt>debian/compat</tt> file or
even by setting and exporting DH_COMPAT in <tt>debian/rules</tt>. If it
is not set in either place, debhelper defaults to the deprecated
......@@ -343,7 +343,7 @@ Info: The package build-depends on debhelper but does not ship a compat
may alternatively Build-Depend on the debhelper-compat virtual package,
For example:
.
Build-Depends: debhelper-compat (= 11)
Build-Depends: debhelper-compat (= 12)
.
Please refer to the debhelper documentation on how to create the
compat file and the differences between each compat level.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment