Commit afdf16d2 authored by Mathieu Parent's avatar Mathieu Parent

Replace multiarch-support by ${misc:Pre-Depends}. This requires debhelper >= 9.

parent 4b3ff7e5
......@@ -2,7 +2,7 @@ Source: lua-posix
Section: interpreters
Priority: optional
Maintainer: Enrico Tassi <gareuselesinge@debian.org>
Build-Depends: debhelper (>= 8.1.3), dh-autoreconf, dh-lua (>= 24~), libncursesw5-dev, lua-bitop, lua-ldoc, lua-discount
Build-Depends: debhelper (>= 9), dh-autoreconf, dh-lua (>= 24~), libncursesw5-dev, lua-bitop, lua-ldoc, lua-discount
Standards-Version: 3.9.3
Vcs-Git: https://anonscm.debian.org/git/pkg-lua/lua-posix.git
Vcs-Browser: https://anonscm.debian.org/git/pkg-lua/lua-posix.git
......@@ -11,7 +11,7 @@ Homepage: https://github.com/luaposix/luaposix
Package: lua-posix
Architecture: any
Multi-Arch: same
Pre-Depends: multiarch-support
Pre-Depends: ${misc:Pre-Depends}
Provides: ${lua:Provides}
Depends: ${shlibs:Depends}, ${misc:Depends}, lua-bitop
XB-Lua-Versions: ${lua:Versions}
......@@ -22,7 +22,7 @@ Description: posix library for the Lua language
Package: lua-posix-dev
Architecture: any
Multi-Arch: same
Pre-Depends: multiarch-support
Pre-Depends: ${misc:Pre-Depends}
Section: libdevel
Provides: ${lua:Provides}
Depends: lua-posix (= ${binary:Version}), ${misc:Depends}
......@@ -37,7 +37,7 @@ Package: lua-curses
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: multiarch-support
Pre-Depends: ${misc:Pre-Depends}
Provides: ${lua:Provides}
Depends: ${shlibs:Depends}, ${misc:Depends}
XB-Lua-Versions: ${lua:Versions}
......@@ -48,7 +48,7 @@ Description: curses library for the Lua language
Package: lua-curses-dev
Architecture: any
Multi-Arch: same
Pre-Depends: multiarch-support
Pre-Depends: ${misc:Pre-Depends}
Section: libdevel
Provides: ${lua:Provides}
Depends: lua-curses (= ${binary:Version}), ${misc:Depends}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment