1. 10 Oct, 2016 1 commit
  2. 24 May, 2015 1 commit
  3. 09 Oct, 2014 2 commits
  4. 11 Sep, 2013 1 commit
  5. 25 Aug, 2013 2 commits
    • Gary V. Vaughan's avatar
      ext/yaml: avoid double include of lua52compat.h. · 03bae4a4
      Gary V. Vaughan authored
      * ext/yaml/yaml.c: lyaml.h already includes lua52compat.h, so no
      need to include it again from here!
      Signed-off-by: 's avatarGary V. Vaughan <gary@gnu.org>
      03bae4a4
    • Gary V. Vaughan's avatar
      maint: maintain API backwards compatibility with legacy C implementation. · 2603ef65
      Gary V. Vaughan authored
      Make sure the old lyaml.load and lyaml.dump APIs work by switching
      the naming of the C and lua parts of the new implementation.
      * ext/lyaml: Rename from this...
      * ext/yaml: ...to this.
      * ext/lyaml/lyaml.c: Rename from this...
      * ext/lyaml/yaml.c: ...to this.
      * lib/yaml.lua: Rename from this...
      * lib/lyaml.lua: ...to this.
      * specs/ext_lyaml_emitter_spec.yaml,
      specs/ext_lyaml_parser_spec.yaml,
      specs/ext_lyaml_scanner_spec.yaml, specs/lib_yaml_spec.yaml:
      Rename from these...
      * specs/ext_yaml_emitter_spec.yaml,
      specs/ext_yaml_parser_spec.yaml,
      specs/ext_yaml_scanner_spec.yaml, specs/lib_lyaml_spec.yaml:
      ...to these.
      * local.mk, specs/specs.mk, specs/spec_helper.lua: Adjust.
      * NEWS: Remove all the incompatibility warnings, and adjust.
      Signed-off-by: 's avatarGary V. Vaughan <gary@gnu.org>
      2603ef65