Commit 5ca396c1 authored by Alf Gaida's avatar Alf Gaida Committed by Andrew Lee

new release 0.9.0

drop patches
add source/options
fix debian $foo
parent 017c032a
lxqt-notificationd (0.8.0-1) unstable; urgency=medium
* Imported Upstream version 0.8.0
* Min liblxqt-qt5-0-dev version 0.8.0
* Min Qt version 5.3.2
* bump standards to 3.9.6
* desktop-file fix OnylShowIn=LXQt;
* add lintian-overrides for missed manpages and invalid category
-- Alf Gaida <agaida@siduction.org> Sun, 19 Oct 2014 00:43:58 +0200
lxqt-notificationd (0.7.96-1) unstable; urgency=low
lxqt-notificationd (0.9.0-1) experimental; urgency=low
* Initial release (Closes: #747602)
-- Alf Gaida <agaida@siduction.org> Wed, 10 Sep 2014 00:54:55 +0200
-- Alf Gaida <agaida@siduction.org> Sun, 15 Feb 2015 03:32:49 +0100
Source: lxqt-notificationd
Section: x11
Priority: optional
Maintainer: Alf Gaida <agaida@siduction.org>
Maintainer: Debian LXQt Maintainers <lxqt-debian@lists.lxde.org>
Uploaders:
Alf Gaida <agaida@siduction.org>
Build-Depends:
cmake,
cmake (>= 3.0.2),
debhelper (>= 9),
libx11-dev,
pkg-config,
liblxqt-qt5-0-dev (>= 0.8.0),
libkf5windowsystem-dev (>= 5.5.0),
liblxqt0-dev (>= 0.8.1),
libqt5x11extras5-dev (>= 5.3.2),
libqt5xdg-dev (>= 1.0.0),
qttools5-dev (>= 5.3.2),
......@@ -17,12 +20,10 @@ Homepage: https://github.com/lxde/lxqt-config
#Vcs-Git: git://anonscm.debian.org/collab-maint/lxqt-config.git
#Vcs-Browser: http://anonscm.debian.org/?p=collab-maint/lxqt-config.git;a=summary
Package: lxqt-notificationd-qt5
Package: lxqt-notificationd
Architecture: any
Breaks:
lxqt-notificationd,
Replaces:
lxqt-notificationd,
Breaks: lxqt-notificationd-qt5 (<< 0.9.0)
Replaces: lxqt-notificationd-qt5 (<< 0.9.0)
Depends:
${misc:Depends},
${shlibs:Depends},
......@@ -33,14 +34,34 @@ Description: LXQt notification daemon
.
This package contain the LXQt notification daemon.
Package: lxqt-notificationd-qt5-dbg
Package: lxqt-notificationd-dbg
Architecture: any
Section: debug
Priority: extra
Breaks: lxqt-notificationd-qt5-dbg (<< 0.9.0)
Replaces: lxqt-notificationd-qt5-dbg (<< 0.9.0)
Depends:
${misc:Depends},
lxqt-notificationd-qt5 (= ${binary:Version}),
lxqt-notificationd (= ${binary:Version}),
Description: LXQt notification daemon (debug symbols)
The LXQt notification daemon
.
This package contain the debugging symbols.
# ---- to be dropped in 2016 ----
Package: lxqt-notificationd-qt5
Depends: lxqt-notificationd, ${misc:Depends}
Priority: extra
Section: oldlibs
Architecture: all
Description: lxqt-notificationd transitional package
Empty package to facilitate upgrades, can be safely removed.
Package: lxqt-notificationd-qt5-dbg
Depends: lxqt-notificationd-dbg, ${misc:Depends}
Priority: extra
Section: oldlibs
Architecture: all
Description: lxqt-notificationd transitional package (dbg)
Empty package to facilitate upgrades, can be safely removed.
......@@ -3,12 +3,12 @@ Upstream-Name: lxqt-notificationd
Source: https://github.com/lxde/lxqt-notificationd
Files: *
Copyright: 2012-2014 LXQt team
Copyright: 2012-2015 LXQt team
2010-2012 Razor team
License: GPL-2.0+ and LGPL-2.1+
Files: debian/*
Copyright: 2014 Alf Gaida <agaida@siduction.org>
Copyright: 2014-2015 Alf Gaida <agaida@siduction.org>
License: LGPL-2.1+
License: GPL-2.0+
......
# there will not be manpages in a foreseable futore
lxqt-notificationd-qt5: binary-without-manpage usr/bin/lxqt-config-notificationd
lxqt-notificationd-qt5: binary-without-manpage usr/bin/lxqt-notificationd
lxqt-notificationd: binary-without-manpage usr/bin/lxqt-config-notificationd
lxqt-notificationd: binary-without-manpage usr/bin/lxqt-notificationd
# LXQt is not in freedesktop specs yet
lxqt-notificationd-qt5: desktop-entry-invalid-category LXQt usr/share/applications/lxqt-config-notificationd.desktop
lxqt-notificationd: desktop-entry-invalid-category LXQt usr/share/applications/lxqt-config-notificationd.desktop
Description: OnlyShowIn fixed
Author: Alf Gaida <agaida@siduction.org>
Last-Update: 2014-10-19
--- lxqt-notificationd-0.8.0.orig/config/lxqt-config-notificationd.desktop.in
+++ lxqt-notificationd-0.8.0/config/lxqt-config-notificationd.desktop.in
@@ -6,6 +6,6 @@ Comment=Configure desktop notifications
Exec=lxqt-config-notificationd
Icon=preferences-desktop-theme
Categories=Settings;DesktopSettings;Qt;LXQt;
-OnlyShowIn=LXQt;LXDE;
+OnlyShowIn=LXQt;
#TRANSLATIONS_DIR=translations
lxqt-config-notificationd.desktop.patch
#!/usr/bin/make -f
#export DH_VERBOSE=1
export USE_QT5=1
%:
......@@ -9,7 +7,7 @@ export USE_QT5=1
override_dh_auto_install:
dh_auto_install -- DESTDIR=$(CURDIR)/debian/lxqt-notificationd-qt5
dh_auto_install -- DESTDIR=$(CURDIR)/debian/lxqt-notificationd
override_dh_strip:
dh_strip --dbg-package=lxqt-notificationd-qt5-dbg
dh_strip --dbg-package=lxqt-notificationd-dbg
tar-ignore=.gitignore
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment