Commit ce9f8f1d authored by Alf Gaida's avatar Alf Gaida

Cherry-picking upstream release 0.11.1.

* Removed some buid dependencies:
  -cmake
  -libqt5xdg-dev
  -libqt5xdgiconloader-dev
  -pkg-config
  -qttools5-dev
  -qttools5-dev-tools
* Bumped build dependency liblxqt0-dev (>= 0.11.1)
* Bumped years in d/copyright
parent f5176a30
build
*/translations/lxqt-notificationd
lxqt-notificationd-0.11.0 / 2016-09-24
lxqt-notificationd-0.11.1 / 2017-01-01
======================================
* Updated da translation. Removed da_DK
* Update and rename French .desktop file
* Make CMakeList.txt more uniform.
* Remove cpack (#53)
0.11.0 / 2016-09-24
===================
* Release 0.11.0: Add changelog
* Update and extend README.md
* Add Catalan translation
* build: Use external translations
......
......@@ -2,33 +2,28 @@ cmake_minimum_required(VERSION 3.0.2 FATAL_ERROR)
project(lxqt-notificationd)
option(UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
include(GNUInstallDirs)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTOUIC ON)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
option(UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
find_package(Qt5Widgets REQUIRED QUIET)
find_package(Qt5DBus REQUIRED QUIET)
find_package(Qt5DBus REQUIRED)
find_package(Qt5LinguistTools REQUIRED QUIET)
find_package(KF5WindowSystem REQUIRED QUIET)
find_package(Qt5Widgets REQUIRED)
message(STATUS "Building with Qt${Qt5Core_VERSION_STRING}")
find_package(lxqt REQUIRED QUIET)
find_package(KF5WindowSystem REQUIRED)
find_package(lxqt REQUIRED)
include(GNUInstallDirs)
include(LXQtCompilerSettings NO_POLICY_SCOPE)
# Translations **********************************
include(LXQtTranslate)
add_subdirectory(src)
add_subdirectory(config)
# building tarball with CPack -------------------------------------------------
include(InstallRequiredSystemLibraries)
set(CPACK_PACKAGE_VERSION_MAJOR ${LXQT_MAJOR_VERSION})
set(CPACK_PACKAGE_VERSION_MINOR ${LXQT_MINOR_VERSION})
set(CPACK_PACKAGE_VERSION_PATCH ${LXQT_PATCH_VERSION})
set(CPACK_GENERATOR TBZ2)
set(CPACK_SOURCE_GENERATOR TBZ2)
set(CPACK_SOURCE_IGNORE_FILES /build/;.gitignore;.*~;.git;.kdev4;temp)
include(CPack)
add_subdirectory(src)
# Translations
GenericName[da]=Notesblok
Name[da]=Strømstyring
Comment[da]=Indstil freedesktop meddelelser på LXQt skrivebord
Name[da]=Skrivebordsnotifikationer
GenericName[da]=LXQt-notifikationsindstillinger
Comment[da]=Konfigurér skrivebordsnotifikationer
# Translations
GenericName[da_DK]=LXQt freedesktop Meddelelsesindstillinger
Name[da_DK]=LXQt freedesktop Meddelelsesindstillinger
Comment[da_DK]=Indstil freedesktop meddelelser på LXQt skrivebord
# Translations
Name[fr]=Paramétrage des notifications
GenericName[fr]=Paramétrage des notifications du bureau LXQt
Comment[fr]=Paramétrage des notifications du bureau LXQt
# Translations
GenericName[fr_FR]=Paramétrage des notifications du bureau
Name[fr_FR]=Paramétrage notifications
lxqt-notificationd (0.11.1-1) unstable; urgency=medium
* Cherry-picking upstream release 0.11.1.
* Removed some buid dependencies:
-cmake
-libqt5xdg-dev
-libqt5xdgiconloader-dev
-pkg-config
-qttools5-dev
-qttools5-dev-tools
* Bumped build dependency liblxqt0-dev (>= 0.11.1)
* Bumped years in d/copyright
-- Alf Gaida <agaida@siduction.org> Mon, 02 Jan 2017 14:01:39 +0100
lxqt-notificationd (0.11.0-2) unstable; urgency=medium
* Cherry-picking upstream release 0.11.0.
......
......@@ -6,18 +6,12 @@ Uploaders: Alf Gaida <agaida@siduction.org>,
Section: x11
Priority: optional
Build-Depends: debhelper (>= 10),
cmake (>= 3.0.2),
libkf5windowsystem-dev,
liblxqt0-dev (>= 0.11.0),
liblxqt0-dev (>= 0.11.1),
libqt5svg5-dev,
libqt5x11extras5-dev,
libqt5xdg-dev (>= 2.0.0),
libqt5xdgiconloader-dev (>= 2.0.0),
libx11-dev,
pkg-config,
qtbase5-private-dev,
qttools5-dev,
qttools5-dev-tools
qtbase5-private-dev
Standards-Version: 3.9.8
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-lxqt/lxqt-notificationd.git/?h=debian/sid
Vcs-Git: https://anonscm.debian.org/git/pkg-lxqt/lxqt-notificationd.git -b debian/sid
......
......@@ -3,12 +3,12 @@ Upstream-Name: lxqt-notificationd
Source: https://github.com/lxde/lxqt-notificationd
Files: *
Copyright: 2012-2016 LXQt team
Copyright: 2012-2017 LXQt team
2010-2012 Razor team
License: LGPL-2.1+
Files: debian/*
Copyright: 2014-2016 Alf Gaida <agaida@siduction.org>
Copyright: 2014-2017 Alf Gaida <agaida@siduction.org>
2015 Andrew Lee (李健秋) <ajqlee@debian.org>
License: LGPL-2.1+
......
......@@ -10,6 +10,6 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
override_dh_auto_configure:
dh_auto_configure -- \
-DPULL_TRANSLATIONS=OFF\
-DUPDATE_TRANSLATIONS=OFF\
-DPULL_TRANSLATIONS=OFF \
-DUPDATE_TRANSLATIONS=OFF \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment