Commit 9f3a044c authored by Alf Gaida's avatar Alf Gaida

Try to load the versioned libfm-qt.so.6 instead of libfm-qt.so

(Closes: #927905)
parent ac642c4c
lxqt-qtplugin (0.14.0-3) unstable; urgency=medium
* Try to load the versioned libfm-qt.so.6 instead of libfm-qt.so
(Closes: #927905)
-- Alf Gaida <agaida@siduction.org> Wed, 24 Apr 2019 23:05:04 +0200
lxqt-qtplugin (0.14.0-2) unstable; urgency=medium
* Added missed direct dependency libqt5xdgiconloader-dev, the new
......
Description: Load the versioned library
Loading libfm-qt.so would not be wise, it would introduce a dependency
to libfm-qt-dev. So hard patching to libfm-qt.so.6 will be fine for
Buster - we will find a better solution upstream for the next release.
Author: Alf Gaida <agaida@siduction.org>
---
Bug-Debian: https://bugs.debian.org/927905
--- lxqt-qtplugin-0.14.0.orig/src/lxqtplatformtheme.cpp
+++ lxqt-qtplugin-0.14.0/src/lxqtplatformtheme.cpp
@@ -239,7 +239,7 @@ QPlatformDialogHelper *LXQtPlatformTheme
// The createFileDialogHelper() method is dynamically loaded from libfm-qt on demand
if(createFileDialogHelper == nullptr) {
// try to dynamically load libfm-qt.so
- QLibrary libfmQtLibrary{QLatin1String("libfm-qt")};
+ QLibrary libfmQtLibrary{QLatin1String("libfm-qt.so.6")};
libfmQtLibrary.load();
if(!libfmQtLibrary.isLoaded()) {
return nullptr;
load-versioned-libfm-qt.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment