Commit dc331fda authored by Axel Beckert's avatar Axel Beckert

New upstream version 2.8.9dev16

parent 386553b0
-- $LynxId: CHANGES,v 1.908 2017/07/04 22:48:35 tom Exp $
-- $LynxId: CHANGES,v 1.918 2017/07/11 00:17:59 tom Exp $
===============================================================================
Changes since Lynx 2.8 release
===============================================================================
2017-07-10 (2.8.9dev.16)
* modify configure script to warn if NLS cannot be configured, and disable
the feature rather than leaving it partly configured and failing during
the build -TD
* modify configure script to allow pre-set $MSGFMT and $XGETTEXT variables to
to used to build the NLS configuration using system's native NLS support -TD
* convert po/zh_TW.po to UTF-8 to work with Solaris10, which lacks big5 -TD
* build-fix for OSX Panther, which has PRId64 but not SCNd64 (patch by Martijn
Dekker).
* modify po-makefile to use msgmerge to align with lynx.pot, and also use sed
to update some obsolete homepage URLs in translations -TD
* add a note in the comments for INCLUDE in lynx.cfg regarding the default
directory searches LYOpenCFG(), added in 2.8.4dev.20 (Debian #818047) -TD
* add a check to ensure that HTML_put_string() will not append a chunk onto
itself (report by Ned Williamson) -TD
* update da.po, et.po, tr.po from
http://translationproject.org/latest/lynx
2017-07-04 (2.8.9dev.15)
* add note in lynx.cfg about default values (Debian #408448) -TD
* amended Backes' change to the COLLAPSE_BR_TAGS feature for compatibility -TD
......
......@@ -501,6 +501,21 @@ II. Compile instructions -- UNIX
--enable-nls (several definitions)
use Native Language Support (i.e., gettext).
This relies upon external programs (msgfmt and xgettext) to format
the message catalogs:
+ Unless you set the environment variables MSGFMT and XGETTEXT to
the full pathnames of these utilities, the configure script will
search for the GNU versions of these utilities.
It will also search for the GNU version of the corresponding
gettext() runtime function. On some platforms (such as Solaris),
this search gives misleading results.
+ If you set those environment variables to full pathnames, the
configure script will warn if they are not the GNU versions of
the utilities.
--enable-nsl-fork (define NSL_FORK)
Disabled by default, this allows interruption of NSL requests,
so that `z' will stop the `look-up' phase of a connection.
......@@ -1467,4 +1482,4 @@ VIII. Acknowledgment
-- 1999/04/24 - H. Nelson <lynx-admin@irm.nara.kindai.ac.jp>
-- vile:txtmode
-- $LynxId: INSTALLATION,v 1.126 2015/09/19 17:40:20 tom Exp $
-- $LynxId: INSTALLATION,v 1.127 2017/07/10 08:55:07 tom Exp $
lynx-dev (2.8.9dev.15) unstable; urgency=low
lynx-dev (2.8.9dev.16) unstable; urgency=low
* maintenance updates
-- Thomas E. Dickey <dickey@invisible-island.net> Thu, 11 May 2017 17:22:30 -0400
-- Thomas E. Dickey <dickey@invisible-island.net> Wed, 05 Jul 2017 16:13:35 -0400
lynx-dev (2.8.8dev.16) unstable; urgency=high
......
# Lynx's version-numbering is not understood by lintian, though legal.
lynx-dev: rc-version-greater-than-expected-version 2.8.9dev.15 > 2.8.9 (consider using 2.8.9~dev.15)
lynx-dev: rc-version-greater-than-expected-version
# This is intentional because it is referenced from the documentation.
lynx-dev: extra-license-file usr/share/doc/lynx-dev/COPYING
......
; $LynxId: lynx.nsi,v 1.36 2017/05/11 21:22:30 tom Exp $
; $LynxId: lynx.nsi,v 1.37 2017/07/05 20:13:35 tom Exp $
; Script originally generated with the Venis Install Wizard, but customized.
; The Inno Setup script is preferred; but this can be built via cross-compiling.
......@@ -9,8 +9,8 @@
!define VERSION_EPOCH "2"
!define VERSION_MAJOR "8"
!define VERSION_MINOR "9"
!define VERSION_LEVEL "1015"
!define VERSION_PATCH "dev.15"
!define VERSION_LEVEL "1016"
!define VERSION_PATCH "dev.16"
!define SUBKEY "Lynx"
......
# $LynxId: lynx.spec,v 1.42 2017/05/11 21:22:30 tom Exp $
# $LynxId: lynx.spec,v 1.43 2017/07/05 20:13:35 tom Exp $
Summary: A text-based Web browser
Name: lynx
Version: 2.8.9
Release: dev.15
Release: dev.16
License: GPLv2
Group: Applications/Internet
Source: lynx%{version}%{release}.tgz
......
; version used for Inno Setup files.
; $Format: "#define LYNX_VERSION \"$ProjectVersion$\""$
#define LYNX_VERSION "2.8.9dev.15"
#define LYNX_VERSION "2.8.9dev.16"
; most-recent full release and target
#define LYNX_RELEASE "2.8.9"
......
/*
* $LynxId: HTUtils.h,v 1.124 2017/07/02 20:40:14 tom Exp $
* $LynxId: HTUtils.h,v 1.125 2017/07/07 20:49:16 Martijn.Dekker Exp $
*
* Utility macros for the W3 code library
* MACROS FOR GENERAL USE
......@@ -585,7 +585,7 @@ extern int WWW_TraceMask;
* Printing/scanning-formats for "off_t", as well as cast needed to fit.
*/
#if defined(HAVE_LONG_LONG) && defined(HAVE_INTTYPES_H) && defined(SIZEOF_OFF_T)
#if (SIZEOF_OFF_T == 8) && defined(PRId64)
#if (SIZEOF_OFF_T == 8) && defined(PRId64) && defined(SCNd64)
#define PRI_off_t PRId64
#define SCN_off_t SCNd64
......
This diff is collapsed.
/*
* $LynxId: config.hin,v 1.139 2016/04/16 00:47:08 tom Exp $
* $LynxId: config.hin,v 1.140 2017/07/06 00:47:43 tom Exp $
* vile:cmode
*
* The configure script translates "config.hin" into "lynx_cfg.h"
......@@ -7,6 +7,8 @@
#ifndef LYNX_CFG_H
#define LYNX_CFG_H 1
#undef HOMEPAGE_URL
#undef ALL_CHARSETS /* AC_ARG_WITH(charsets) */
#undef ALT_CHAR_SET /* CF_ALT_CHAR_SET */
#undef ARCHIVE_ONLY /* CF_ARG_DISABLE(dired-archive) */
......
This diff is collapsed.
dnl $LynxId: configure.in,v 1.290 2017/07/02 18:18:00 tom Exp $
dnl $LynxId: configure.in,v 1.292 2017/07/06 00:48:30 tom Exp $
dnl
dnl Process this file with autoconf to produce a configure script.
dnl
......@@ -29,7 +29,7 @@ dnl ---------------------------------------------------------------------------
dnl
dnl ask PRCS to plug-in the project-version for the configure-script.
dnl $Format: "AC_REVISION($ProjectVersion$)"$
AC_REVISION(2.8.9dev.15)
AC_REVISION(2.8.9dev.16)
# Save the original $CFLAGS so we can distinguish whether the user set those
# in the environment, or whether autoconf added -O and -g options:
......@@ -64,7 +64,7 @@ AC_ARG_PROGRAM
PACKAGE=lynx
dnl ask PRCS to plug-in the project-version for the packages.
# $Format: "VERSION=$ProjectVersion$"$
VERSION=2.8.9dev.15
VERSION=2.8.9dev.16
AC_SUBST(PACKAGE)
AC_SUBST(VERSION)
......@@ -1561,6 +1561,10 @@ if test -n "$srcdir" ; then
test "$srcdir" != "." && SRCDIR_CLEAN=""
fi
HOMEPAGE_URL="http://lynx.invisible-island.net/"
AC_DEFINE_UNQUOTED(HOMEPAGE_URL,"$HOMEPAGE_URL",[Define to Lynx homepage URL])
AC_SUBST(HOMEPAGE_URL)
AC_SUBST(SRCDIR_CLEAN)
AC_OUTPUT(
[makefile \
......
# $LynxId: lynx.cfg,v 1.285 2017/07/04 22:57:01 tom Exp $
# $LynxId: lynx.cfg,v 1.288 2017/07/11 08:45:14 tom Exp $
# lynx.cfg file.
# The default placement for this file is /usr/local/lib/lynx.cfg (Unix)
# or Lynx_Dir:lynx.cfg (VMS)
#
# $Format: "#PRCS LYNX_VERSION \"$ProjectVersion$\""$
#PRCS LYNX_VERSION "2.8.9dev.15"
#PRCS LYNX_VERSION "2.8.9dev.16"
#
# $Format: "#PRCS LYNX_DATE \"$ProjectDate$\""$
#PRCS LYNX_DATE "Thu, 11 May 2017 17:22:30 -0400"
#PRCS LYNX_DATE "Tue, 11 Jul 2017 04:45:14 -0400"
#
# Definition pairs (configuration settings) are of the form
# VARIABLE:DEFINITION
......@@ -60,12 +60,18 @@
#
# INCLUDE:/usr/local/lib/lynx.cfg
# ^^^^^^^^^^^^^^^^^^^^^^^ or whatever is appropriate on your system
# and now your own tweaks.
# and now your own tweaks. If you omit the directory name, e.g.,
#
# Starting with Lynx 2.8.2, the INCLUDE facility is yet more powerful. You can
# suppress all but specific settings that will be read from included files.
# This allows sysadmins to provide users the ability to customize lynx with
# options that normally do not affect security, such as COLOR, VIEWER, KEYMAP.
# INCLUDE:lynx.cfg
#
# then lynx first checks if it is in any of the directories listed in the
# environment variable LYNX_CFG_PATH, then tries the directory of the default
# config-file.
#
# You can also suppress all but specific settings that will be read from
# included files. This allows sysadmins to provide users the ability to
# customize lynx with options that normally do not affect security, such as
# COLOR, VIEWER, KEYMAP.
#
# The syntax is
#
......
# $LynxId: makefile.in,v 1.162 2017/05/11 21:22:30 tom Exp $
# $LynxId: makefile.in,v 1.164 2017/07/06 08:46:09 tom Exp $
##makefile for lynx
SHELL = @CONFIG_SHELL@
......@@ -46,7 +46,7 @@ TAR_UP = $(TAR) @TAR_UP_OPTIONS@ @TAR_PIPE_OPTIONS@
TAR_DOWN = $(TAR) @TAR_DOWN_OPTIONS@ @TAR_PIPE_OPTIONS@
# $Format: "LYNX_VERSION = $ProjectVersion$"$
LYNX_VERSION = 2.8.9dev.15
LYNX_VERSION = 2.8.9dev.16
## This is the version which we are developing (or, upon release, make this
## the same). Use no dots in the name, since it must work on VMS and MS-DOS.
......@@ -347,7 +347,7 @@ install-doc : $(DOCDIR) $(HELPDIR)
# So we limit sed delimiters to '!' and '%', depending on the expected text.
FIX_SED = tr '=' '"'
LYNX_URL='http://lynx.invisible-island.net/release/breakout'
LYNX_URL='@HOMEPAGE_URL@release/breakout'
LYNXDOCS_URL='$(LYNX_URL)/docs/'
LYNXHELP_URL='$(LYNX_URL)/lynx_help/'
......
This diff is collapsed.
This diff is collapsed.
#, fuzzy
msgid ""
msgstr ""
"Project-Id-Version: lynx 2.8.9dev.15\n"
"Project-Id-Version: lynx 2.8.9dev.16\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2017-07-04 16:51-0400\n"
"POT-Creation-Date: 2017-07-06 04:38-0400\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
......@@ -3693,31 +3693,31 @@ msgstr ""
msgid "Y/N/A/V"
msgstr ""
#: src/HTML.c:5932
#: src/HTML.c:5943
msgid "Description:"
msgstr ""
#: src/HTML.c:5937
#: src/HTML.c:5948
msgid "(none)"
msgstr ""
#: src/HTML.c:5941
#: src/HTML.c:5952
msgid "Filepath:"
msgstr ""
#: src/HTML.c:5947
#: src/HTML.c:5958
msgid "(unknown)"
msgstr ""
#: src/HTML.c:7387
#: src/HTML.c:7398
msgid "Document has only hidden links. Use the 'l'ist command."
msgstr ""
#: src/HTML.c:7885
#: src/HTML.c:7896
msgid "Source cache error - disk full?"
msgstr ""
#: src/HTML.c:7898
#: src/HTML.c:7909
msgid "Source cache error - not enough memory!"
msgstr ""
......
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment