Commit c9c83ab3 authored by Andreas Tille's avatar Andreas Tille

Try to run unit tests which failed blatantly with bioperl 1.7.1. Just commit...

Try to run unit tests which failed blatantly with bioperl 1.7.1.  Just commit this status to enable other reproducing this without any decision whether the final package should remain with the unit tests.
parent 2f4acaf3
bioperl-run (1.6.9-4) UNRELEASED; urgency=medium
* Testsuite: autopkgtest-pkg-perl
* cme fix dpkg-control
* Enable lots of tests
TODO: not sure whether this should remain for the package release but
for the moment we need to verify functionality with latest bioperl
* Fix homepage
-- Andreas Tille <tille@debian.org> Fri, 16 Dec 2016 09:17:37 +0100
bioperl-run (1.6.9-3) unstable; urgency=medium
[ Charles Plessy ]
......
......@@ -3,11 +3,12 @@ Maintainer: Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.
Uploaders: Charles Plessy <plessy@debian.org>,
Andreas Tille <tille@debian.org>
Section: science
Testsuite: autopkgtest-pkg-perl
Priority: optional
Build-Depends: debhelper (>= 9)
Build-Depends-Indep: perl,
libmodule-build-perl,
bioperl (>= 1.6.9),
bioperl,
# Recommended in Build.PL:
libalgorithm-diff-perl,
libipc-run-perl,
......@@ -15,18 +16,38 @@ Build-Depends-Indep: perl,
libxml-twig-perl,
# Not yet available: libfile-sort-perl
# Needed for the tests, but not documented Upstream
libtest-most-perl,
libarray-compare-perl,
libtree-dagnode-perl,
# Needed for the regression tests: all Recommends of bioperl-run except embassy, that needs interactive setup.
# amap-align, bedtools, blast2, bowtie, bwa, clustalw, emboss, exonerate,
# hmmer, infernal, kalign, maq, mafft, muscle, phyml, primer3, probcons,
# samtools, sim4, t-coffee, tigr-glimmer, wise,
amap-align,
bedtools,
blast2,
bowtie,
bwa,
clustalw,
emboss,
exonerate,
hmmer,
infernal,
kalign,
maq,
mafft,
muscle,
phyml,
primer3,
probcons,
samtools,
sim4,
t-coffee,
tigr-glimmer,
wise,
# Needed for the network tests:
libwww-perl
Standards-Version: 3.9.6
Standards-Version: 3.9.8
Vcs-Browser: http://anonscm.debian.org/viewvc/debian-med/trunk/packages/bioperl-run/trunk/
Vcs-Svn: svn://anonscm.debian.org/debian-med/trunk/packages/bioperl-run/trunk/
Homepage: http://www.bioperl.org/wiki/Run_package
Homepage: http://search.cpan.org/dist/BioPerl-Run/
Package: bioperl-run
Architecture: all
......@@ -48,6 +69,7 @@ Recommends: amap-align,
maq,
mafft,
muscle,
phylip,
phyml,
primer3,
probalign,
......@@ -57,13 +79,11 @@ Recommends: amap-align,
t-coffee,
tigr-glimmer,
wise
Suggests:
# Non-Free.
gmap,
paml,
Suggests: gmap,
paml
# Removed from Debian at all molphy,
# Removed from Debian but might be reintroduced ensembl,
phylip
# The following list of packages is not available in Debian:
# blat,
# cap3,
......
......@@ -4,6 +4,9 @@ ifneq (,$(DEB_MAINTAINER_MODE))
NETWORK = --network
endif
SKIPTESTS=Glimmer2 \
RepeatMasker
%:
dh $@
......@@ -11,4 +14,8 @@ override_dh_auto_configure:
dh_auto_configure -- --install_scripts $(NETWORK)
override_dh_auto_test:
# PATH=$$PATH:/usr/lib/emboss dh_auto_test
mkdir t.skip
for t in $(SKIPTESTS) ; do mv t/$${t}.t t.skip ; done
PATH=$$PATH:/usr/lib/emboss dh_auto_test
mv t.skip/* t
rm -rf t.skip
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment