Commit 314bd480 authored by Sebastien Jodogne's avatar Sebastien Jodogne

preparing for 0.6-1

parent a3720aa9
orthanc-wsi (0.5-3) UNRELEASED; urgency=medium
orthanc-wsi (0.6-1) UNRELEASED; urgency=medium
* New upstream version
* Updated d/upstream/metadata with new reference paper about Orthanc
* Fix FTBFS with dcmtk 3.6.4, Closes: #919742
-- Sebastien Jodogne <s.jodogne@gmail.com> Fri, 04 May 2018 12:24:21 +0200
-- Sebastien Jodogne <s.jodogne@gmail.com> Sat, 26 Jan 2019 14:18:06 +0100
orthanc-wsi (0.5-2) unstable; urgency=medium
......
......@@ -18,7 +18,7 @@ Build-Depends: cmake,
uuid-dev,
yui-compressor,
zlib1g-dev
Standards-Version: 4.1.4
Standards-Version: 4.3.0
Vcs-Browser: https://salsa.debian.org/med-team/orthanc-wsi
Vcs-Git: https://salsa.debian.org/med-team/orthanc-wsi.git
Homepage: http://www.orthanc-server.com/static.php?page=wsi
......
......@@ -4,11 +4,11 @@ Upstream-Contact: Sebastien Jodogne <s.jodogne@gmail.com>
Source: https://bitbucket.org/sjodogne/orthanc-wsi/
Files: *
Copyright: 2012-2016 Sebastien Jodogne <s.jodogne@gmail.com>, University Hospital of Liege (Belgium), and 2017-2018 Osimis S.A. (Belgium)
Copyright: 2012-2016 Sebastien Jodogne <s.jodogne@gmail.com>, University Hospital of Liege (Belgium), and 2017-2019 Osimis S.A. (Belgium)
License: AGPL-3+
Files: Resources/Orthanc/*
Copyright: 2012-2016 Sebastien Jodogne <s.jodogne@gmail.com>, University Hospital of Liege (Belgium), and 2017-2018 Osimis S.A. (Belgium)
Files: Resources/Orthanc/* debian/ThirdPartyDownloads/Orthanc-1.5.2.tar.gz
Copyright: 2012-2016 Sebastien Jodogne <s.jodogne@gmail.com>, University Hospital of Liege (Belgium), and 2017-2019 Osimis S.A. (Belgium)
License: GPL-3+ with OpenSSL exception
Files: debian/JS/openlayers-3.19.0/*
......
Description: Fix the version of the shared library
Author: Sebastien Jodogne <s.jodogne@gmail.com>
Author: Sebastien Jodogne <s.jodogne@orthanc-labs.com>
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
Index: OrthancWSI-0.5/ViewerPlugin/CMakeLists.txt
Index: OrthancWSI-0.6/ViewerPlugin/CMakeLists.txt
===================================================================
--- OrthancWSI-0.5.orig/ViewerPlugin/CMakeLists.txt
+++ OrthancWSI-0.5/ViewerPlugin/CMakeLists.txt
@@ -197,9 +197,10 @@ add_library(OrthancWSI SHARED
--- OrthancWSI-0.6.orig/ViewerPlugin/CMakeLists.txt
+++ OrthancWSI-0.6/ViewerPlugin/CMakeLists.txt
@@ -198,9 +198,10 @@ add_library(OrthancWSI SHARED
)
message("Setting the version of the library to ${ORTHANC_WSI_VERSION}")
......
......@@ -29,11 +29,11 @@ override_dh_auto_configure:
# Put 3rd party packages where the cmake build system expects them
mkdir -p Applications/ThirdPartyDownloads
( cd Applications/ThirdPartyDownloads && \
ln -s ../../debian/ThirdPartyDownloads/Orthanc-1.3.2.tar.gz . )
ln -s ../../debian/ThirdPartyDownloads/Orthanc-1.5.2.tar.gz . )
mkdir -p ViewerPlugin/ThirdPartyDownloads
( cd ViewerPlugin/ThirdPartyDownloads && \
ln -s ../../debian/ThirdPartyDownloads/Orthanc-1.3.2.tar.gz . )
ln -s ../../debian/ThirdPartyDownloads/Orthanc-1.5.2.tar.gz . )
# Configure the command-line tools
mkdir BuildApplications
......
debian/ThirdPartyDownloads/Orthanc-1.3.2.tar.gz
debian/ThirdPartyDownloads/openlayers-3.19.0-dist.zip
debian/ThirdPartyDownloads/Orthanc-1.5.2.tar.gz
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment