...
 
Commits (2)
binutils-mingw-w64 (8.3) UNRELEASED; urgency=medium
* Move to the team repository on Salsa.
* Make DLL import libraries reproducible. Closes: #915055; thanks to
Benjamin Moody for the patch.
-- Stephen Kitt <skitt@debian.org> Fri, 07 Dec 2018 21:06:57 +0100
binutils-mingw-w64 (8.2) unstable; urgency=medium
* Adjust to binutils 2.30.90.20180627.
......
......@@ -12,8 +12,8 @@ Build-Depends: debhelper (>= 11~),
symlinks,
zlib1g-dev
Standards-Version: 4.1.4
Vcs-Browser: https://salsa.debian.org/debian/binutils-mingw-w64
Vcs-Git: https://salsa.debian.org/debian/binutils-mingw-w64.git
Vcs-Browser: https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64
Vcs-Git: https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
Homepage: https://www.gnu.org/software/binutils/
Package: binutils-mingw-w64
......
Description: Make DLL import libraries reproducible
Author: Benjamin Moody <benjamin.moody@gmail.com>
Bug-Debian: https://bugs.debian.org/915055
--- a/upstream/ld/pe-dll.c
+++ b/upstream/ld/pe-dll.c
@@ -2844,6 +2844,7 @@
bfd_set_format (outarch, bfd_archive);
outarch->has_armap = 1;
+ outarch->flags |= BFD_DETERMINISTIC_OUTPUT;
/* Work out a reasonable size of things to put onto one line. */
ar_head = make_head (outarch);
......@@ -2,3 +2,4 @@ testsuite-timeout.patch
specify-timestamp.patch
dont-run-objcopy.patch
default-secure-pe-flags.patch
reproducible-import-libraries.patch