Commit 6587b7f5 authored by James Cowgill's avatar James Cowgill

Upload to unstable

parent 0c3c7ab1
ffdiaporama (2.1+dfsg-1) UNRELEASED; urgency=medium
ffdiaporama (2.1+dfsg-1) unstable; urgency=medium
* Imported Upstream version 2.0.1
* Team upload.
[ James Cowgill ]
* New upstream release. (Closes: #731777)
* Remove background resources. These resources are not released under a DFSG
free license.
* debian/compat:
- Use debhelper compat 11.
* debian/control
- Set maintainer to debian-multimedia@l.d.o.
- Build depend on qtbase5-dev instead of qt5-default.
- Drop dependency on ffmpeg.
- Drop shlibs:Depends from ffdiaporama-data.
- Bump standards version to 4.1.3.
- Set Rules-Requires-Root: no.
- Mark ffdiaporama-data as Multi-Arch foreign.
* debian/copyright:
- Update for 2.1.
* debian/ffdiaporama-data.links:
- Add a dummy background to prevent segfaults.
* debian/patches:
- Rename and refresh 01_fix-hardening-flags.patch.
- Update and split up ffmpeg patches.
- Add patch to fix uninitialized variable valgrind warnings.
- Add patch to make LibAvLogCallback thread safe.
- Add patch to enable rsc subproject.
- Add patch to fix 64-bit architecture detection.
- Add patch to prevent phoning home for updates.
- Add patch to fix FTBFS with FFmpeg 4.0. (Closes: #888354)
* debian/rules:
- Remove DH_VERBOSE comment from debian/rules.
- Install upstream changelog.
- Export QT_SELECT in debian/rules.
* debian/watch:
- Update debian/watch to new source location.
[ Rico Tzschichholz ]
* Update fix_hardening_flags.patch
* Add ffmpeg_2.8.patch for ffmpeg 2.8+ support
* Explicitly use ffDiaporama.pro
* Install application icon
* Use ffmpeg >= 2.8 and QT5
* Add ffmpeg_2.8.patch for ffmpeg 2.8+ support.
* Install application icon. (LP: #1280820)
* Use ffmpeg >= 2.8 and QT5. (Closes: #873191, #874874)
[ Ondřej Nový ]
* d/copyright: Use https protocol in Format field
* d/control: Deprecating priority extra as per policy 4.0.1
* d/control: Set Vcs-* to salsa.debian.org
-- Rico Tzschichholz <ricotz@ubuntu.com> Tue, 19 Apr 2016 19:50:19 +0200
-- James Cowgill <jcowgill@debian.org> Thu, 22 Feb 2018 21:40:49 +0000
ffdiaporama (1.5-5) unstable; urgency=medium
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment