Commit bfdbebc2 authored by Andreas Beckmann's avatar Andreas Beckmann

[i386 armhf] add transitional nvidia-settings

parent d7b16414
nvidia-settings (410.104-2) UNRELEASED; urgency=medium
* [i386 armhf]: Reinstate nvidia-settings as a transitional package
depending on nvidia-settings-legacy-390xx.
-- Andreas Beckmann <anbe@debian.org> Thu, 28 Mar 2019 19:35:02 +0100
nvidia-settings (410.104-1) unstable; urgency=medium
* New upstream release 410.104.
......
......@@ -30,21 +30,22 @@ Vcs-Git: https://salsa.debian.org/nvidia-team/nvidia-settings.git
Package: nvidia-settings
Section: contrib/x11
Architecture: amd64
Architecture: amd64 i386 armhf
Pre-Depends:
nvidia-installer-cleanup,
Depends:
${nvidia-alternative},
libxnvctrl0 (= ${binary:Version}),
nvidia-settings-legacy-390xx [!amd64],
${nvidia-alternative} [amd64],
libxnvctrl0 (= ${binary:Version}) [amd64],
${shlibs:Depends}, ${misc:Depends}
Recommends:
libgl1-nvidia${nvidia:Legacy}-glvnd-glx | libgl1-nvidia${nvidia:Legacy}-glx,
nvidia${nvidia:Legacy}-vdpau-driver,
libnvidia${nvidia:Legacy}-ml1,
libgl1-nvidia${nvidia:Legacy}-glvnd-glx [amd64] | libgl1-nvidia${nvidia:Legacy}-glx [amd64],
nvidia${nvidia:Legacy}-vdpau-driver [amd64],
libnvidia${nvidia:Legacy}-ml1 [amd64],
Provides:
nvidia-settings-gtk-${nvidia:Version},
nvidia-settings-gtk-${nvidia:Version} [amd64],
Conflicts:
nvidia-settings-gtk-${nvidia:Version},
nvidia-settings-gtk-${nvidia:Version} [amd64],
Description: tool for configuring the NVIDIA graphics driver${nvidia:LegacyDesc}
The nvidia-settings utility is a tool for configuring the NVIDIA
Linux graphics driver. It operates by communicating with the NVIDIA
......
no-upstream-changelog
# the shared libraries are actually version-specific plugins
package-name-doesnt-match-sonames
shlib-calls-exit
no-symbols-control-file
[amd64]: package-name-doesnt-match-sonames
[amd64]: shlib-calls-exit
[amd64]: no-symbols-control-file
# On architectures no longer supported by the current driver,
# this is a dummy package depending on the 390xx legacy driver.
[!amd64]: empty-binary-package
[!amd64]: package-contains-no-arch-dependent-files
......@@ -48,7 +48,7 @@ AUTOCLEAN = $(filter-out $(AUTOKEEP),$(AUTOGEN))
%:
dh $@
ifeq (,$(filter nvidia-settings,$(shell dh_listpackages)))
ifneq (amd64,$(DEB_HOST_ARCH))
override_dh_auto_build: $(AUTOGEN)
CC_ONLY_CFLAGS="$(CPPFLAGS)" dh_auto_build --sourcedirectory=src/libXNVCtrl
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment